Sketchup Pro 2021 30 day trial crashed and won't reopen

Hi - day 1 of my 30 day trial using Sketchup Studio on an iMac and it’s not a success… I only had a few objects and tags created in my file when the prog unexpectedly crashed and won’t reopen. It’s in a loop of showing me the Bug Splat Error report (which I’ve now sent multiple timesIncident Identifier.pdf (233.2 KB) ), then a Sketchup quit unexpectedly box (which Ive tried to Ignore, Report and Reopen). Then nothing happens and I try to reopen it again and the same thing occurs… Ive rebooted my Mac but the problem persists. I downloaded Sketchup from your the Sketchup website. Advice would be welcome… thank you.

Remove the folder from the Applications in the trash, empty the trash and click on the installer file (disk image)
When the panel pops up with two icons, drag the icon of SketchUp in that of the Application folder.
Close that panel and remove the disk image from the desktop
Open Finder and navigate to the applications and find SketchUp inside the SketchUp 2021 folder.

Thanks. I tried that but same problem, except this time I get the Agreement window pop up before it crashes (Bug splat/Error loop).

But you can’t sign it?
Please note that the bugsplats that appear upon opening are actually from the session before!

Did you send in any of the bugsplats?

The agreement window should only appear if you have been into the application support folder and deleted the settings files.

Or, is there any chance you are running SketchUp from the disk image or from a location that isn’t in Applications?

I could sign it, but then it crashed again.

Yes I’ve hit ‘send’ on all the bugsplats but there’s no confirmation that any got sent - not sure if there should be.
I have tried to reinstall sketchup from the download I originally did (when it worked for 1 day), but this crashes. I then deleted everything related to Sketchup, emptied the trash, and tried to install from the Sketchup website, this brought up the Agreement then crashed and is again only bringing up crash info boxes.
I’ve rebooted my machine several times too.

Could you check for a direct message from me?