Sketchup 2016 - locking up

Greetings. Upgraded to SU 2016 (make). Ive been working on a project, but now SU is locking up randomly. At first, everything worked fine. Ive tried everything - GPU update, MS update, running w/o plugins… I even reinstalled and SU worked fine for about an hour before locking up again. No other software is locking up. I can play games and roll at 100+ FPS and all is fine. Can watch video… and all is fine. The only thing locking up is SU. No changes have been made to my PC, other then Nvidia update (of which I rolled back to see if issue persists…and it does) In short, SU is locking up for no apparent reason whatsoever. NONE. Ive tried other save files… still locks up. Tried other save files on the 2015 version and it too locks up (whereas 2015 version never locked up…) So, now both 2015 and 2016 version are locking up. Again, no changes had been made prior to the issue. Monitoring my system shows no spikes in CPU, GPU, or disk usage while the issue occurs.

Ive used SU since its initial release and never had any issue. My rig is very capable if running SU - 64bit quad, GTX 860, 8Gb memory, 1 Tb HDD… Not to mention games run flawlessly and at high FPS. Ive tried everything. Any idead why SU is locking up? Is the 2016 bugged? If so, why is my 2015 version locking up as well? (When it never had before, that is, untill the 2016 install) Could a duo install be causing the issue? If so, why had all worked fine for weeks?

Please help. Thank you.

Is the work model file on the local harddrive, or in a virtual drive (like DropBox) ?

If so, work on a local file, and copy to a virtual drive (sync up the virtual drive) AFTER closing SketchUp.

1 Like

Im working on a local drive.

In Preferences > OpenGL. (A recent display driver updates might be causing issues.)

Try (one at a time):

  • disabling Hardware Acceleration
  • disabling Maximum texture size
  • choosing a different mode in the “Capabilities” list


My system is more then capable of running SU… I went ahead and checked those settings… SU still locks up.

Here is what ive discovered: SU is disabling my mouse. I can use my PC and all works well. I open up SU and within minutes the freezing begins. Again, my PC runs flawlessly otherwise. If I use SU and then close it out, the mouse issue/freezing persists. In short, SU is HIGHLY bugged and is causing major issue with my PC. Why this has worked its way down to the 2015 version is beyond me. At any rate, I went ahead and removed both apps and removed any remaining folders/files and deleted all known reg keys. Im working with my PC and its running fine.

This issue totally sucks as Ive used SU since its release. It is my prefered 3D app, but noe it appears that I will be forced to switch apps. Thanks for the memories SU, it was fun while it lasted. :smiley:

Have you tried updating your mouse driver? Use Logitech SetPoint? Those drivers can become corrupted too. In my case it only affected SU.

Have not updated that driver. Currently finishing up system maintnencr and the will check for new driver.

Well… I did a full system maintnence and cleanup… Checked all drivers and installed updated where needed. Reinstalled SU and all worked fine for about an hour… AND… bam, right back to the same thing. This is messed up. Sketchup is bugged badly. My system is fine and runs like a champion. I habe no other choice but to blame this software. What I find disturbing is how it can just ‘all of a sudden’ bug out, and for no reason. Not only that, the fact that my 2015 install was corrupt, is also confusing. Whatever happened it appears that I can no longer use this software. Thanks Sketchup! FFS, what a joke.

Clean up and maintenance is not the end - just the beginning.

Maintain IE - clear cache, update flash, security set to medium? SU15 and 16 are separate installs. What they have in common is using IE.

Did you check if SU runs in safe mode and clean boot?

I did all if that… except safe mode boot.

Save a log of running processes when in safe mode. Safe mode > open SU > get log. That is if SU runs OK.

Try clean boot as well. It’s less restrictive - video driver is used. Get process log too.

Get log in normal mode. If there’s an interfering process, use the logs to eliminate. There are suppose to be some tools under Administrative that will save logs. I’ve used HijackThis to make logs.

To be thorough, go to C:\Program Files\SketchUp\SketchUp 2016 > r-click on SketchUp.exe > Properties > Compatibility > check Run this program as administrator? Same with SU15. Though I seem to be doing fine without this being checked…

If you have a multiple monitor set up, be sure to run SU on main monitor…

I run it as admin… And, using a laptop so just 1 monitor.

What are you usually doing when it ‘locks up’?

Have you used it with a second monitor at some stage or has it always been 1 monitor?
Have you tried using a different mouse?
Have you tried uninstalling the specific mouse driver an allowed to run with a generic mouse driver?

It could very well be the mouse. About a month ago, I had a number of problems which “suddenly” appeared with sketchup. Mouse worked fine in other windows programs. I traded mice with another computer and all was well. About a week later, when using the first mouse on the other computer, I realized the mouse did, in fact, have a problem. The artifacts were subtle, but I think they showed up more using sketchup than when using a more basic program. Mice wear out, particularly with the use they get in sketchup.

One thing that hasn’t been suggested:
Have you checked in the 3D application settings of the Nvidia control panel that SketchUp is set to use the Nvidia graphics (specifically, not via Automatic selection)?


What is the mouse make, model, it’s driver version number ?

Agreed. Try a mainstream 3 button wheel-mouse. (Microsoft preferred.)

Ive tried everything. Performed a complete system overhaul and maintnence. All drivers are updated. I use a wireless trackball mouse. Its a Logitech m570.

Now I have more issue. The locking up is happening while using Windows or while playing games. I suspect it is the mouse, but for themost part it works fine. The majority of the freezing happens when using SU. I thought maybe it was my PC overheating, but my mouse was completely dead upon first boot this morning. Had to restart several time before it worked. The mouse itself appears to be ok as it is registered in Windows. As for SU, I reinstalled it and it seems to be bugged in its own accord. The save file thumbnails no longer appear on my current saves. At times, I go to scroll out and it zooms FAR away from the model. If I click on the model and try to scroll in… it scrolls rights past it. Instead of scrolling ‘one frame at a time’, its scrolling like 100 frames… The openGL settings are also not being saved.

In short… There is no consistent pattern to this issue. At first it was limited to SU only, but has noe gone system wide. As mentioned, my system is clean and well maintained. It very well may be the mouse itself, but curious as to why I can go hours with no issues then suddenly have nothing but. I will get a new mouse and see if the issue persists.

I just noticed in you profile you say Win10, did you upgrade to Win10 or did it come pre installed?

I found that Win 10 doesn’t work with a specific class of graphic driver, of which mine was so I had to downgrade to Win7 to get everything working again.
When you mention that the opengl setting won’t save, that was my sticking point, couldn’t make SU run in win10 with the Nvidia card.

1 Like

I have the GTX 860m… Driver is updated and WQHL. Im gonna assume it is the mouse. Will buy new mouse tomorrow and report my findings.