2016 no longer displays


#1

Hello, I can no longer access my .skp files on my Windows 7 SP1 16GB RAM, 64bit PC. I upgraded SU Make 2015 to SU Make 2016 and for a time had no issues using SU 2016 and saved files just fine. I had been using a 3 monitor setup with the 3rd monitor on a USB display driver. Already have an AMD Radeon HD 5450 installed. One of my monitors failed and I replaced it with an Acer H276HL bmid 27-Inch (1920 x 1080) monitor and installed an additional graphics card PCI-e x1 ATI Radeon HD 5400 Series thinking I could eliminate the USB driven display. This was all plug and play, I did not have to perform any special system configurations modifications. After the new installs everything on my PC works great, Adobe CS5 Masters Collection, Firefox, Chrome, IE, YouTube & Amazon Prime video, Office 2013. You get the picture. Now, when I double click my SketchUp project.skp file I get the SketchUp splash screen but when I choose a template and click the “Start using SketchUp” button the splash screen disappears and nothing else happens. However, I can see SketchUp.exe running in the Windows Task Manager “Processes” tab. When I try and uninstall SU 2016 it sees that SketchUp.exe is running and cannot automatically stop it during uninstall. I have to manually end the SketchUp.exe process. I’m a week behind scouring forums so, I removed the new graphics card and went back to a single monitor, uninstalled SU 2016 and installed SU 2014. SU 2014 displays the splash on startup and proceeds as normal when clicking the “Start” button. When I double click my project.skp file I get a popup dialog error message:
“The file was created in a newer version of SketchUp.
You have version 14.1.1282.
You need version 16.0.19912.
Please visit sketchup.com to get the latest version.” Which kind of proves I was able to get SU 2016 working at some point on my PC. I reinstalled the latest version (SU 2016) provided by sketchup.com. Now, as before, when I double click my SketchUp project.skp file I get the SketchUp splash screen but when I choose a template and click the “Start using SketchUp” button the splash screen disappears and nothing else happens. Wish I could post pictures. All my drivers seem to be up to date and working properly. SketchUp Pro 2016 “Layout” works without issue (seems to think I have 2 days left of the trial SU Pro 2016 version). SketchUp Style Builder 2016 displays a popup dialog indicating I have 2 days left of SketchUp Pro (I only need SketchUp Make but didn’t have a choice during install upgrade from SU 2015) but when I acknowledge the popup dialog it goes away and nothing else happens. I can see Style Builder.exe running in the Windows Task Manager “Processes” tab. I have to manually end the Style Builder.exe process too.
I would really like to continue working on my project but at this point I can’t even go backwards. Thank you for any help and your patience.


#2

Was the SketchUp display previously on the monitor that crashed? My suspicion is that SketchUp is trying to show on the monitor that is no longer present. That’s a catch-22, since you could probably fix it with reset workspace, but you have to be able to see SketchUp to run that! The bad value is probably stuck in the registry somewhere, but I’ll have to defer to a Windows guru for where, as Trimble does not document its registry usage.


#3

I’d just blow away all registry settings and start over. 3 monitors? Wow.


#4

Thank you for your reply. It (SU 2016) behaves the same no matter if Win 7 thinks I’m using 3 monitors or 1. I’m currently back to just one monitor (one my other Acer’s that I know was previously working without issues) while I troubleshoot this issue. I verified via the Windows Control Panel\All Control Panel Items\Display\Screen Resolution that there is only one connected display on the manufacturers video card (no ghosts). I’m trying to remember if there was an update to SU after I switched from 2015 to 2016. I only just installed the new video card and monitor weekend before last.


#5

Thank you for the suggestion of blowing away the registry settings. Is there already a forum thread that indicates exactly what registry keys need to be deleted using regedit.exe or can you supply that information please?


#6

I tried the steps detailed in this Google search http://www.advanceduninstaller.com/SketchUp-2015-46a6f8228366e29a9b6040a249cc19a0-application.htm to no avail. Verified no “SketchUp” or “Trimble” entries in registry. Rebooted. Reinstalled SU 2016. Still not working. Behaves same as described in original post.


#7

Once you ok the splash screen wait a moment to let SU load then hit alt+space bar then m then any arrow key then (without clicking) move the mouse around and see if SU comes into view.


#8

I understand what you’re trying to do but there would have to be a window instance created first in order for a window to be moved. I performed this test anyway and it did not produce any SketchUp windows hiding in any of the four directions around my monitor nor did it change the mouse cursor from an arrow pointer to a four arrow headed crosshair indicating a window was getting ready to be moved after entering the alt+spacebar+m command. Still no dice. Weird.


#9

That is odd, are you getting any indication of a window opening off screen? an SU icon in the task bar?
One more try to grab it.
Do alt+spacebar then r then alt+spacebar then m etc

Alt spacebar r will restore down from full screen to allow you to grab it with the move.

But if you are not getting any indication of a window anywhere it probably wont work.


#10

Yep, I tried the alt+spacebar+r while I was trying the last test. No go.
So, I did a complete uninstall of all versions of SU, Used all options of CCleaner to scour my PC, reinstalled my second graphic card (ATI Radeon HD 4500 series) reconnected my other two Acer monitors (one via HDMI and one DVI, the third monitor is connected via DVI on the native AMD Radeon HD 5450) and rebooted. I found an old copy of SU 2014 (14.1.1282) and installed and am able to use SU 2014 on all 3 monitors no problems. I also found an old copy of SU 2015 (15.3.331 64-bit) and installed and am able to use SU 2015 on all 3 monitors no problems. I can run both SU 2014 & SU 2015 simultaneously with no issues.
I still cannot open my project.skp file that was saved in 2016 so I’ll just have to start over in SU 2015.
LESSON LEARNED, MAKE BACKUPS OF YOUR PROJECT FILES IN THE VERSION OF SKETCHUP YOU ARE UPGRADING FROM.
At some point I would like to know the resolution to this problem and be able to use SU 2016 again. Perhaps the next update to SU 2016 will fix this. Until then, I’m back to work on SU 2015 (15.3.331 64-bit).


#11

That is very strange.

However, if you need your project saved back to 2015 attach it or PM it and it can be easily converted.


#12

Well, spoke too soon. Neither SU 2014 or SU 2015 will save a file. Whenever I click “Save” in the dialog box I get spinning mouse cursor and the SketchUp window title updates to (Not Responding). I have to start Window Task Manager to end the SketchUp application process. I’ve never had a problem with SketchUp until SU 2016 was installed. Frustrating.


#13

Are you able to save if you disable hardware acceleration in Window > Preferences > OpenGL?


#14

Hmm… I’m on Windows 7 SP1. I’m not familiar with that path. I did a right mouse click on the desktop and chose “Screen resolution”. I clicked on the corresponding display in the “Change the appearance of your displays” section then clicked “Advanced settings”. I then clicked on the “Troubleshoot” tab. The “Change settings” button is disabled for both of my video cards.
This is really starting to concern me. Unfortunately, I’ve uninstalled/reinstalled several different SU versions so many times trying to troubleshoot this I can’t go back to a restore point prior to the installation of SU 2016 (big assumption on my part that would have an effect).


#15

@catamountain is referring to within Sketchup.

Open SU and look for the Window menu top toolbar, then scroll down to Preferences, and click the OpenGl tab and change the settings there. Restart SU and see if it fixes anything. This tests to see if your graphic card is the problem.


#16

In SU itself, go to Window > Preferences > OpenGL. You may need to restart SU. This bypasses your graphic driver. This is done as a test to see if some deficiency with your graphic driver was involved in this issue.

I know of at least one person with an AMD graphic card that could not save unless hardware acceleration was disabled going back to SU14.


#17

Sorry I didn’t understand the first time. So I started up SU 2015 (15.3.331 64bit), I went to Window>Preferences>OpenGL and unchecked the “Use hardware acceleration” check box. I exited SU 2015 and restarted. Created a simple rectangle and was able to save the file and export as 2D Graphic. As expected, using the Orbit tool is sluggish now and surfaces do not render while in motion. Thank you for that. Does this lead us to a next step or an understanding of what’s happening? It would be nice to use SU at full speed.

In case anyone is keeping track:
+++Did work with “Use hardware acceleration” checked:
File>Export>3D Model
File>Import>project2.skp

—Did NOT work with “Use hardware acceleration” checked:
File>Export>2D Graphic
File>Save
File>Save As


#18

My “Thank you for that” could be misconstrued as being snarky. I really am thankful for that tip. Please do not take that the wrong way.


#19

You also can try just disabling hardware acceleration when you want to export and save without restarting SU. And try with one of your files (make a backup copy through your window browser to be safe.)

SU uses some OpenGL function in saving SKP files. And judging by your test, it may be involved in exporting too. AMD has a spotty record in providing OpenGL support required by SU.

Apparently you had good graphic driver prior your your monitor problem. By any chance did your recently update your driver? If so you can rollback the driver to the last one you had.


#20

I did a right mouse click on the desktop and chose “Screen resolution”. I clicked on the corresponding display in the “Change the appearance of your displays” section that’s associated with my AMD/ATI Radeon 5450 then clicked “Advanced settings”. On the “Adapter” tab I clicked on the “Properties” button. On the next popup dialog I clicked on the driver tab. I then clicked the “Roll Back Driver” button then, clicked the “OK” button. I rebooted my PC. Sarted SU 2015 (with “Use hardware acceleration” checked) and I can now save a file. However, my new 27" Acer that I installed with the new ATI HD Radeon 5400 series graphic card is not utilizing all the available screen. The HDMI cable for the 27" monitor is not even connected to the graphic card that had the rolled back driver.
Also interesting to note in the SU 2015 Window>Preferences>OpenGL “Capabilities” section it shows:
Colors=True Color, Precision=Medium, Shadows=Yes for #'s 3,12,15.
Prior to rolling back the driver it showed:
Colors=True Color, Precision=High, Shadows=Yes for #3
Colors=True Color, Precision=Medium, Shadows=No for #12
Colors=True Color, Precision=High, Shadows=Yes for #15