Plugin Curic Installation - SketchUp 2022 - M1 mac

I’m having problems with version 2022 mac M1 and installing Curic plugins. Is it happening to you too? has anyone managed to solve the problem?

I’m on PC and have had no problems with Curic’s plugins and 2022.

Is it specifically installing them?

That is, from the extension manager in SketchUp you cannot install the plugins?

Here is the error that gives me … I think it is a problem related to the Mac Arm version … once installed correctly the plugin does not work and when restart it gives me the following writing also by installing with any version of the Curic Plugin.

Error: #<LoadError: dlopen(/Users/Nicola/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_extend/clib/bundle/2.7/Extend.bundle, 0x0009): tried: ‘/Users/Nicola/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_extend/clib/bundle/2.7/Extend.bundle’ (mach-o file, but is an incompatible architecture (have ‘x86_64’, need ‘arm64e’)), ‘/usr/local/lib/Extend.bundle’ (no such file), ‘/usr/lib/Extend.bundle’ (no such file) - /Users/Nicola/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_extend/clib/bundle/2.7/Extend.bundle>

/Applications/SketchUp 2022/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.7.1/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’

/Applications/SketchUp 2022/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.7.1/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’

/users/nicola/library/application support/sketchup 2022/sketchup/plugins/curic_extend/loader.rbe:45:in `module:Extend

/users/nicola/library/application support/sketchup 2022/sketchup/plugins/curic_extend/loader.rbe:13:in `module:CURIC

/users/nicola/library/application support/sketchup 2022/sketchup/plugins/curic_extend/loader.rbe:6:in `’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `eval’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `require’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `load’

/Users/Nicola/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_extend.rb:20:in `register_extension’

/Users/Nicola/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_extend.rb:20:in `module:Extend

/Users/Nicola/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_extend.rb:4:in `module:CURIC

/Users/Nicola/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_extend.rb:3:in `<top (required)>’

Similar to…?

Not suggesting that Jack’s (MikeWayzovski) suggestion will work for you.

Hey @curic4su any ideas?

Hey @curic4su any ideas?

[quote=“nicolabarbagligeom, post:3, topic:188080”]
(mach-o file, but is an incompatible architecture (have ‘x86_64’, need ‘arm64e’)
[/quote]

Is it possible for the ARM version for mac M1 to come into conflict?

It looks like you have tried to load an x86 compiled bundle. If you did not run SketchUp under Rosetta, then Curic will need to supply an ARM compiled (or universal) binary for the extension.

In the meantime, you will need to run SketchUp under Rosetta in order to load this extension.

REF:

Too bad that the Sketchup 2022 installer during installation does not make you choose whether to use the Intel version or the ARM version. With M1 I can only use the ARM version. So I can’t use Curic plugins in this case.

It’s less a question of the SketchUp installer than of macOS. SketchUp 2022 is distributed as a “universal (aka fat) binary”, meaning it contains both ARM and Intel versions in the same package. The macOS launch service decides that the ARM version is the right one to run if you have an M1 Mac. See the link @DanRathbun posted above regarding a way to force macOS to run the Intel version.

1 Like

However, the fact remains that with the Mac and M1 versions Curic plugins have some problems … how can I solve it.

1 Like

Only Curic can solve it. Sorry. Best to contact them.

I have contacted Curic and they said they were working on a solution. Keeping the thread alive in hopes of a solution arriving soon.

2 Likes

Has anyone found a solution for this? I wrote Curic again but no reply this time.

I also tried to contact him but I had no answers about it, the problem I believe in art architecture maybe not supported by its plugins. Too bad because I work a lot with its plugins.

I heard that he still have not any Mac with M1 so he may not have solved the problem yet.

Just keeping this thread alive in hopes that there will be a fix soon. I bought the Studio package and still can’t use it.

Problem is Curic he currently not have enough money for a new Macbook M1 to run and test code in that environment, i guess.

I will keep checking in in hopes that this will someday start working on M1