Curic Studio

Has anyone had luck getting the CURIC studio to work on a M1 mac with Sketchup 2022? It will not load unless I use rosetta. Seems to be in conflict with Fredo also.

Error: #<LoadError: dlopen(/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_!studio/clib/bundle/2.7/Studio.bundle, 0x0009): tried: ‘/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_!studio/clib/bundle/2.7/Studio.bundle’ (mach-o file, but is an incompatible architecture (have (x86_64), need (arm64e))) - /Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_!studio/clib/bundle/2.7/Studio.bundle>

/Applications/SketchUp 2022/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.7.1/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’

/Applications/SketchUp 2022/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.7.1/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_!studio/loader.rbe:27:in `module:Studio

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_!studio/loader.rbe:7:in `module:CURIC

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_!studio/loader.rbe:1:in `’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `eval’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `require’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `load’

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_!studio.rb:27:in `register_extension’

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_!studio.rb:27:in `module:Studio

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_!studio.rb:5:in `module:CURIC

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_!studio.rb:3:in `<top (required)>’

Error: #<LoadError: dlopen(/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_dio2/clib/bundle/2.7/DIO2.bundle, 0x0009): tried: ‘/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_dio2/clib/bundle/2.7/DIO2.bundle’ (mach-o file, but is an incompatible architecture (have (x86_64), need (arm64e))) - /Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_dio2/clib/bundle/2.7/DIO2.bundle>

/Applications/SketchUp 2022/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.7.1/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’

/Applications/SketchUp 2022/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.7.1/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_dio2/loader.rbe:94:in `module:DIO2

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_dio2/loader.rbe:49:in `module:CURIC

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_dio2/loader.rbe:42:in `’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `eval’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `require’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `load’

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_dio2.rb:23:in `register_extension’

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_dio2.rb:23:in `module:DIO2

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_dio2.rb:5:in `module:CURIC

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_dio2.rb:3:in `<top (required)>’

Error: #<LoadError: dlopen(/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_extend/clib/bundle/2.7/Extend.bundle, 0x0009): tried: ‘/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_extend/clib/bundle/2.7/Extend.bundle’ (mach-o file, but is an incompatible architecture (have (x86_64), need (arm64e))) - /Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_extend/clib/bundle/2.7/Extend.bundle>

/Applications/SketchUp 2022/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.7.1/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’

/Applications/SketchUp 2022/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.7.1/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_extend/loader.rbe:45:in `module:Extend

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_extend/loader.rbe:13:in `module:CURIC

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_extend/loader.rbe:6:in `’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `eval’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `require’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `load’

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_extend.rb:20:in `register_extension’

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_extend.rb:20:in `module:Extend

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_extend.rb:4:in `module:CURIC

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_extend.rb:3:in `<top (required)>’

Error: #<LoadError: dlopen(/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_hidden/clib/bundle/2.7/Hidden.bundle, 0x0009): tried: ‘/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_hidden/clib/bundle/2.7/Hidden.bundle’ (mach-o file, but is an incompatible architecture (have (x86_64), need (arm64e))) - /Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_hidden/clib/bundle/2.7/Hidden.bundle>

/Applications/SketchUp 2022/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.7.1/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’

/Applications/SketchUp 2022/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.7.1/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_hidden/loader.rbe:42:in `module:Hidden

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_hidden/loader.rbe:11:in `module:CURIC

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_hidden/loader.rbe:4:in `’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `eval’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `require’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `load’

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_hidden.rb:22:in `register_extension’

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_hidden.rb:22:in `module:Hidden

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_hidden.rb:4:in `module:CURIC

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_hidden.rb:3:in `<top (required)>’

Error: #<LoadError: dlopen(/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_oi/clib/bundle/2.7/OI.bundle, 0x0009): tried: ‘/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_oi/clib/bundle/2.7/OI.bundle’ (mach-o file, but is an incompatible architecture (have (x86_64), need (arm64e))) - /Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_oi/clib/bundle/2.7/OI.bundle>

/Applications/SketchUp 2022/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.7.1/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’

/Applications/SketchUp 2022/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.7.1/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_oi/loader.rbe:57:in `module:OI

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_oi/loader.rbe:23:in `module:CURIC

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_oi/loader.rbe:16:in `’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `eval’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `require’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `load’

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_oi.rb:22:in `register_extension’

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_oi.rb:22:in `module:OI

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_oi.rb:5:in `module:CURIC

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_oi.rb:3:in `<top (required)>’

Error: #<LoadError: dlopen(/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_section/clib/bundle/2.7/Section.bundle, 0x0009): tried: ‘/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_section/clib/bundle/2.7/Section.bundle’ (mach-o file, but is an incompatible architecture (have (x86_64), need (arm64e))) - /Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_section/clib/bundle/2.7/Section.bundle>

/Applications/SketchUp 2022/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.7.1/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’

/Applications/SketchUp 2022/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.7.1/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_section/crs_loader.rbe:119:in `module:SECTION

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_section/crs_loader.rbe:72:in `module:CURIC

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_section/crs_loader.rbe:63:in `’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `eval’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `require’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `load’

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_section.rb:28:in `register_extension’

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_section.rb:28:in `module:SECTION

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_section.rb:4:in `module:CURIC

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_section.rb:3:in `<top (required)>’

Error: #<LoadError: dlopen(/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_section_view/clib/bundle/2.7/SectionView.bundle, 0x0009): tried: ‘/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_section_view/clib/bundle/2.7/SectionView.bundle’ (mach-o file, but is an incompatible architecture (have (x86_64), need (arm64e))) - /Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_section_view/clib/bundle/2.7/SectionView.bundle>

/Applications/SketchUp 2022/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.7.1/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’

/Applications/SketchUp 2022/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.7.1/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_section_view/loader.rbe:36:in `module:SectionView

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_section_view/loader.rbe:13:in `module:CURIC

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_section_view/loader.rbe:2:in `’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `eval’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `require’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `load’

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_section_view.rb:22:in `register_extension’

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_section_view.rb:22:in `module:SectionView

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_section_view.rb:4:in `module:CURIC

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_section_view.rb:3:in `<top (required)>’

Error: #<LoadError: dlopen(/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_stretch/clib/bundle/2.7/Stretch.bundle, 0x0009): tried: ‘/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_stretch/clib/bundle/2.7/Stretch.bundle’ (mach-o file, but is an incompatible architecture (have (x86_64), need (arm64e))) - /Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_stretch/clib/bundle/2.7/Stretch.bundle>

/Applications/SketchUp 2022/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.7.1/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’

/Applications/SketchUp 2022/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.7.1/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_stretch/loader.rbe:43:in `module:Stretch

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_stretch/loader.rbe:9:in `module:CURIC

/users/tonypope/library/application support/sketchup 2022/sketchup/plugins/curic_stretch/loader.rbe:2:in `’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `eval’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `require’

/Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `load’

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_stretch.rb:22:in `register_extension’

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_stretch.rb:22:in `module:Stretch

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_stretch.rb:5:in `module:CURIC

/Users/tonypope/Library/Application Support/SketchUp 2022/SketchUp/Plugins/curic_stretch.rb:3:in `<top (required)>’

As with your other question, it looks like the extension hasn’t been updated for arm64. You could watch this discussion to see if there are any updates:

I have some extensions that are not updated as well. I went into /Applications/SketchUp 2022/, and duplicated SketchUp.app. I set the duplicate to run using Rosetta, and I use that one if I need to run those extensions. The rest of the time I run the native version.

1 Like

Thanks. I just did the same thing with the duplicate SketchUp version.