Not possible to print a dead-simple figure in real size if not a professional? (answer: margins and window-fit)

size
printing
2d-export

#1

Hi… I have tried everything to print a figure in a regular home printer. For simplification I have reduced the figure to a simple 250x200cm rectangle which should fit an A4 paper. But sketchup keeps dividing it in two or more pages.

Here you can see one of the settings (I have tried all there though), you can see bottom left indicates pages 1 to 8 with indicates that there will be 8 pages (other times is just two)

I have tried everything I’ve read in other posts:
printing actual size
printing SU drawings in actual size
Printing Views of a Model in Microsoft Windows
Print to scale
please-help-im-really-struggling-to-scale
printing-to-fit-page
printing-or-exporting-1-1-scale-is-this-possible
printing-trouble-multi-page-tiled-at-full-size

Nothing works! Sketchup was really simple to use, so it looked like well suited for small quick easy things non pros do, now I think I probably wasn’t right, as this (so simple…) task takes tremendous time/efforts…
Anyway, just in case: reducing the window size doesn’t help, at least in SU 2017 as it reduces the size of the drawing accordingly…
I have even tried @DanRathbun 's template posted in
Printing to fit pageprinting to fit page
I reduced his/your cube to my size, so that it could fit an A4 paper but still nothing changes…

Hopefully I just have a stupid day and have missed something plainly obvious, but… oh well, any guide on this, even if it was “you just can’t do it” or “you should start learning another x program” would be very much appreciated…


#2

@Val - Try shrinking the entire window to match the aspect ratio of the paper. See this for more info:


#3

Also be sure to go to Camera>Parallel Projection.


#4

Jim makes a good point. I see nothing in your post that indicates you resized the SketchUp window to fit tightly around the model.


#5

Thanks @jimhami42, but as I said, shrinking the window, also shrinks the drawing (maybe a 2017 “feature”?), so no way …


#6

Mi pic showed parallel projection, didn’t it? But good try, thanks @davidheim1


#7

First size the window so that its aspect closely matches that of your paper, that is, so that the ratio of length to width is the same as you paper. Then zoom extents so that your model view fits tightly in the resized window. Then try the print.


#8

The SketchUp print routine seems to assume about 25 mm print margins (somewhat too large IMO), so a 200 mm wide rectangle will not fit on an A4 page (210 mm) whatever you do. Most printers require more than 5 mm margins so this won’t work in most other software either.

Anssi


#9

Mmm, that helped as I don’t think I had achieved having the window frame the drawing so tightly:

yet …

still 2 pages. The pic above is the first one


#10

In one of the topics you gave a link to, did you notice that someone solved the problem by both checking Fit to page and unchecking Use model extents?


#11

How large is the rectangle? What are the margins that your printer requires?


#12

BTW, is your page set to Portrait or Landscape? Your screenshots look like your paper orientation is different from the orientation of your rectangle[quote=“colin, post:10, topic:41069”]
by both checking Fit to page and unchecking Use model extents?
[/quote]
That will disable printing to scale.

Anssi


#13

Thanks @Anssi, I have now included a pic (above) in landscape mode. The lenght of an A4 is 296 mm, so it should be enough… Wait,
ooooohhh…
It was at least partially me having a stupid day…
Yes 200 is too big for the height of an A4 with the margins included… reducing it, does work (!). At least in Preview mode. Trying now printing to see if it keeps the actual size…


#14

Well, this is me on the issue so far :sweat_smile:


#15

Ooooooooooooooohhhhhhhhhhhh…
Everything works now… I’m too tired of so many frustrated intents and a little bit dumbfounded to really experience happiness…, but it will came in a few minutes…
Many, many thanks @Anssi, @slbaumgartner, @jimhami42, @DaveR, @colin and all…
I’m already starting to breathe differently, happiness will come in a while :slight_smile:
People in this forum really rocks…!


#16

@filibis I had 2 or 3 of them too after changing the scale. And restarting that doc didn’t help.
Go to another sketchup doc with a different settings, open the print preview or anything where you can change the scale and it will work again.
Well maybe that’s too much too assume, but it worked for me. You may need to experiment a little bit, but the issue seems to have something to do with the scale settings wrongly saved (in my case there was nothing in “in the printout”, and opening a SU doc that has them right could restore them (you probably need to have the wrong one closed while doing this. In my case were the new ones that kept that wrong setting but I just went to another two that I already had open and now all works ok…


#17

exactly , SU restoring last saved setting (that comes empty dimension) and i crash everytime i pick a dimension here:


#18

So, did closing the malfunctioning doc, saving another working document and reopening the wrong one again worked for you?


#19

In case is of any interest to anyone, the maximum length you can get into an A4 (296mm large), is 275 mm, which is exactly what I needed.
But you have to trim the margins so that they practically don’t exist:

It results in a printed sheet with a 5mm margin on the left… Yet it has almost 2 cm on the right, so maybe someone is able to reduce that margin to something close to the left margin…


#20

The off-center thing is probably due to the drivers and the way the margins are setup. You could probably screw around with it to find a happy medium for those margins.