Problem printing 1:1 actual size on A4 in SketchUp Make on Mac

I have a design in 3D that I need to print (top view) on A4. The print will be a template that I need to cut it out in wood. (See attachment 1)

I can’t get it to be printed right. The object size is 64.5mm (H) x 280.72mm (L). Printing it on A4 lengthwise might be just to small for the printer to fit in it’s printable area. So I also tried to rotate it diagonally, to make it fit better in the printable area.

What I did:

  • In Camera menu, select Parallel Projection
  • In Camera menu > select Standard Views > Top
  • In File menu, select Page Setup > Paper Size A4 & Orientation Landscape
  • In File menu, select Document Setup > uncheck Fit View to Page
    Furthermore I experimented in the Document Setup with Print size values and Print Scale values. I assumed that Print Scale in Drawing has to be equal in Model to make sure the print is actual size. But I also notice that if I change values at Print Scale, they affect Print Size values (and vice versa).

Question
I am probably doing something wrong, but I don’t know what.
Who can help me out?

adjust your ‘viewport’ [SU model window] to exactly 1:1.414 ratio …

tip: draw a 210 X 297 rectangle, delete the face and ‘group’ it as a positional guide.

position the ‘paper outline’ group around your piece…

’ Zoom Extents’ and then centralise your mouse and rotate one notch at a time until the outline just disappears… [just redo ZE if you mess this step up]

set your printer to 'borderless…

john’

Adjust the size of the model space window so it’s aspect ratio matches the paper and then zoom extents.

Thanks John & Dave for your quick replies!

I have followed the suggestion draw an A4 size box around my object and adjust the model space window, so that the A4 box has just disappeared.

Next I checked my Page Setup, see picture 1 in attachment.
Then I checked my Document Setup, see picture 2 in attachment. Here I only adjusted the Printscale In Model to match the Print Scale in Drawing (at 25).

Then I went to print and I could see already in the preview that the print would only show the left half of my object. And printing it showed the same is in the preview, see picture 3 in attachment.

So I am still doing something wrong. Any suggestions?

SketchUp - Actual Size Printing.pdf (119.1 KB)

Upload the SKP.

Here it is Dave.

BT Speaker Casing - Print Test v0.1g-2.skp (317.7 KB)

I have about 5 such objects that I need to print as a template to cut out wood. So your help is really appreciated!

It looks like your pattern is just long enough to run over the margins so it’s getting split to fir on more than one page. You could print the two pages and tape them together or you could rotate the model about 20 degrees so it sits diagonally on the page and fits within the margins. Or, since the thing is symmetrical, you could just cut it in half and print that. Then flip it to make the other side.

I think your right Dave. I guess the printable area of my printer results in this. Unfortunately my printer is A4 max. I think I will generate a PDF for an A3 size printer and see if that works.

By the way, am I correct about the “Print Scale” settings in “Document Setup”? That the values have to be equal to get a print of the actual size?

Is this just a one-off sort of thing?

Yes. You are correct about the print scale thing. 1:1 is full size.

It’s a casing for a bluetooth speaker. If it works I will probably doing more of them for friends.

Thnx about confirming the 1:1 = full size.

One more thing. I have now centered my object within an A3 size rectangle. If I now zoom out, so the rectangle is just not visible anymore … will there be a difference if I just zoomed it out or zoomed it out a bit more then just zoomed out?

There shouldn’t be a difference as long but I find that doing this sort of thing tends to be easiest when you just use Zoom Extents. Once you have the model space window aspect ratio matching the rectangle you drew, delete the rectangle. You don’t need it anymore. Then hit Zoom Extents so the model fills the space as much as possible.

don’t forget sticky tape works well if you cut the item in half and reposition the pieces…

for ‘really’ accurate view sizing your can play with this in Ruby Console…


Sketchup.active_model.active_view.zoom_extents.zoom(1.0525)

different monitors may need a tweek to the last 2 digits…

I’d put the outline and guides on a Layer and tun it on/off, and reverse the faces to save on coloured ink…

my printer has B/W only setting thats great for patterns…

john

rotate the object to fit it on the page better?

Set up a plan-view [Top].
Use my tool:
https://sketchucation.com/pluginstore?pln=Rotateplanview
to rotate the view, by say 30°…
Make a grouped [unfaced] rectangle, drawn to the size of an A4 page.
If appropriate, offset the edges inwards to allow for your printer-margins.
Overlay the A4 outline over your form.
Rotate the A4 outline in the opposite direction, by say -30°.
Adjust it to overlay your form, so that it’s wholly inside the A4 rectangle…
Zoom extents.
Now try printing as outlined in earlier posts…

Thanks all for the tips and suggestions. Using a temporary rectangle at A4 or A3 size worked well. I have the prints and the objects are in the right (1:1) scale.

Thanks again!

Note too that using the “Use model extents” option when printing doesn’t work with objects smaller than about a foot diameter.