Problem printing to 1:1 scale


#1

Hi, guys. I’m having a problem printing from Sketchup Make on Mac OSX El Capitan at a 1:1 scale and hoping to get some advice. I have followed the instructions I have been able to find online but the print out is still off by a fractional amount. These are the steps I am following.

  1. Switch to Parallel Projection
  2. Select Standard Views - Top
  3. Resize window so that only what I want printed is visible
  4. Select Page Setup and configure for 8.5x11 at 100% scale
  5. Select Document Setup, uncheck Fit View to Page, and set Print Scale to 1" in Drawing:1" In Model
  6. Print

I have a model that’s 3" by 2 3/16" which I have confirmed using the Tape Measure tool in the software. The print out, however, is slightly larger at 3 11/16" x 2 10/16". I can’t figure out why. Any ideas? Thanks.


#2

Hi Kevin,

I’m not familiar with the SketchUp Make for Mac print setup interface.
However, I’m quite familiar with the Windows version.

If you’ll share the file I’ll print it to PDF for you.
If you’d rather not share the file publicly, then click my avatar and send a Private Message.


#3

I have a Mac. If you were to upload the model (or if it is confidential, send it to me by PM) and I’ll try here. Might be a printer calibration issue, but I’m guessing. I’ve not had a problem like that myself.

One thing I half remember from another post is that the Document Setup dialogue MAY not update unless you tab out of the scale setting before clicking Print or Ok, or whatever closes that dialogue, so perhaps the 1" in drawing to 1" in model might not ‘stick’.


#4

I have never had any ‘luck’ without resizing the SU viewport to the exact paper ratio first…

hold a piece of printer paper on your screen and adjust the SU ‘model’ viewport to match…

or use a plugin…

I also use ‘print margin less’ with my HP printer…

john


#5

Hey, guys. Thanks for the help. It looks like I have this working now. There is a drop down in the print dialog set to Sketchup. I changed it to Layout and did a test print and the dimensions were right. I’m very new to Sketchup and I don’t know what that setting is. It’s not labelled and I haven’t seen it mentioned in any of the help articles I’ve read. I’d like to understand what that setting is for but I’m content to just accept that it’s working too.


#6

Once you have passed the 30 day trial period for SU Make (which is what you said you have) you will lose the use of Layout. If you don’t intend or need to buy Pro (which you have to have for any commercial use) it’s worth learning how to print to scale within SketchUp itself.

Layout is the separate program for producing 2D documentation from 3D SketchUp models. Only comes with Pro version, after trial expires.

Not sure where you are finding that Layout selection - not at my computer now so can’t look till tomorrow.


#7

That’s odd then because the 30 day trial is expired. This is personal use and I don’t have the money to upgrade to Pro. The selection is in the dialog box when I choose File - Print. It’s right under the the setting for the range of pages to print. It’s not labelled so, I don’t know what it’s for exactly.


#8

I’ll have a look on my machine tomorrow and see what I can work out.


#9

Hi,

I’d take those settings at face value. They look like there just Page Titles for various print settings.

In this case the Layout option isn’t referring to LayOut the companion software to SU, but instead it’s offering options for adjusting the ‘Page Layout’ and paper handling.

Ideally to avoid confusion, this probably should be named ‘Page Layout’, or something similar.


#10

JimD got there before me - the settings are indeed just names for various print settings, and nothing to do with the Layout program - sorry I misled you there. That particular setting (“Layout”) is to adjust printing multiple output pages on one sheet of paper, and in what order to place the pages on the sheet.

i cannot reproduce your problem with the printout not being to scale. Works fine here when I print a rectangle the size you specified.

I still think it is possible that until you had clicked something else, after setting the Scale to 1" in Drawing to 1" in Model, that the setting may not have registered.


#11

Better late than never. This is funny, it being the 21st century and all, but what I did was got out a ruler, held it up to my screen, sized the drawing to scale (in my case, I wanted 1" on screen to equal 1" on paper, so I sized it to full scale), and commenced printing. You will have to orient the drawing, the layout, and select the pages you want, according to your own needs.

I believe “Layout” refers to the Pro feature which those of us weekend warriors probably won’t shell out for, even though it does accomodate 2D and scaling much more gracefully than Sketchup.