Problems printing to scale from SketchUp

printing

#1

Hello

I don’t print much from SketchUp and it shows! I’m trying to print a very simple plan, but in Document Setup it keeps changing the Print Scale. I imported a pdf file and have drawn a plan over it and when I set the Print Scale (yes, I deselected “Fit View to Page”), it accepts it and then when I click OK and then go back into the menu, the settings have changed. To be specific, I’m trying to print a plan a 1/16 scale and I put 1" in the In Drawing box and 16" in the In Model box.
Any advice? Thanks!


#2

Is the scene you’ve selected for printing setup with the camera set to Parallel Projection?

What size paper are you trying to print to? Have you adjusted the model window aspect ratio to match that of the paper?

Share the SKP file and we can help you better.

What version of SketchUp are you using? Please update your profile to include that.


#3

What is the exact problem? Is it that the fields for paper size an model size are disabled?

If so, make sure you have parallel projection and view the model along one of the coordinate axes (top, front, left etc).

In perspective view there is no one scale as there is a perspective foreshortening. The latter is some arbitrary rule SketchUp decided to introduce, and I don’t think anyone knows why really. Mathematically you can have a defined scale regardless of camera orientation, but for some reason SketchUp doesn’t allow it.


#4

Oh, also make sure “Fit to page” isn’t ticked.


#5

Hello

Yes, it’s set to Parallel Projection.
I’m trying to print on A4 paper, and I know it’ll take two sheets.

How do I share the file?

I’m using the latest version of SU, 2018.


#6

The problem is that it doesn’t save the scale I choose in “Document Setting/Print Scale.”

I have the view set to “Top” in Parallel Projection.


#7

Yes, see my original post.


#8

Use the Upload button, 7th from the left in the row above the window where you type you message.

Why not use LayOut, then? Printing to scale is so much easier in LO.


#9

Gregory House.skp (305.1 KB)

There. It’s uploaded (I hope!).

I tried in LayOut too, but didn’t have any better success. And the info I found through a web search about how to do this wasn’t any help either.


#10

Got it. Hang on while I make some screen shots.


#11

1/16 scale


#12

When I write “Printing to scale in Layout” in the Layout Help Center page, I get a page called “Exporting or Printing Your LayOut Document” and under printing to scale, the only information (under 4. Printing your Document) is how to print as a % of 100%. I’m afraid this isn’t helpful.


#13

As I mentioned before, adjust the drawing window space to closely fit the model. Like this.

Then you should be able to set the scale. I haven’t got a printer that handles A4 paper so I can’t select that size but when I set the scale to 1:16, it shows that it’ll require 240 letter size sheets.

Setting this up in LayOut would be so much easier. If you’re interested, I’ll show you how.


#14

I’m sending a screenshot of what I see in Print Preview. As you can see, there’s no option to choose the scale at this point.
The second screen shot is of the Document Setup menu. If I change it so it says 1" - In Drawing and 16" - In Model, and click OK, then when I open it again, it’s back to these numbers.

Yes, I’d love to know how to print to scale in LayOut.


#15

I’ve already written this twice. You need to resize the drawing window to fit the shape of the model. You clearly aren’t doing that.

Here’s a PDF created in LayOut. I set it up to print the model on two A4 sheets in Portrait orientation. The scale is set to 1/16" = 1’-0" That’s 1:192 not the 1:16 that you have been trying to use.
Gregory House.pdf (547.4 KB)

The setup is easy enough. Send the file to LayOut. Select the A4 portrait paper template.

With the viewport selected, go to the SketchUp Model window and select the scale.

Drag the edges of the viewport if needed to show the entire model. In order to spread it across two sheets, orient it as shown below.

Go to the Pages menu and click Duplicate. Then, with the viewport selected, Hold Shift and the left cursor (arrow) key to shift the viewport over like this:

Then File>Export>PDF.

If you were printing this on a single sheet the setup would be quicker but either way, this is much more predictable than printing it in SketchUp.

I mean that you need to change the size of the SketchUp window on screen. Look at the first screen shot I posted in my reply after getting your model. The entire SketchUp screen, window, user interface was resized so that the drawing window is close to the same proportions as the model.


#16

I’m sorry if I’m not doing this right, but it’s because I don’t understand. What do you mean by resizing the drawing window to fit the model? Do you mean the light blue lines around the plan?

Is there a clear explanation of this anywhere on the web? As I mentioned before, the only reference I’ve seen to printing to scale in LayOut is about adjusting the %.


#17

There are a number of books available on using LayOut. There are also Help files in the Learning section on the SketchUp website.

I added direction specific to your request, above.


#18

Thank you very much for the detailed explanation. I did it and it worked! (no surprise of course, but very nice).

I appreciate your patience and your help. I’ll look for those Help files on the SketchUp web site.

I hope you have a very pleasant rest of the day.


#19

I’m glad it worked for you. You have a great day, too.