Trying to print 1:1 using parallel project and camera view from top not working


#1

Hello,

I try to print scaled model 1:1 and whatever I do, sketchup will either print wrong dimensions or will skip parts of the model. I use parallel projection and the camera view from top. The various settings including the model screenshot are attached in the zip file as I cannot post more than 1 image(new account here). When I try to print, the print preview will change while just switching between different pages.
Archive.zip (1.0 MB)
What is wrong?

Jerremy


Print to scale produces wrong printout and causes problems in view
#2

You should uncheck the “Use model extents” checkbox in the Print dialog and zoom in so that your model fills the SketchUp screen, and, if necessary, resize your SketchUp window so that there is as little empty space around your model as possible. This stops the printout from splitting across many pages. There is a bug and the “Use model extents” setting doesn’t work with models smaller than about 300 mm across. Another way is to scale your model up by, say, 10x, and print to 1:10 scale.

SketchUp by default prints everything that is visible in your application window, including the empty space.

Anssi


#3

Thanks for the reply Anssi. Unfortunately there is no “Use model extents” checkbox in the Print dialog on Mac version of sketchup. Nevertheless the idea with having 1:10 or 1:100 scale looks promising. What I want to achieve is to get i.e. 70cm cut template to print over multiple pages with the precise dimensions. There seems to be as well the bug with the preview on Mac where the preview will get damaged while using forward/backward buttons in the preview (Print dialog). I will try with the 1:10 and will come back with the results.


#4

Hello Anssi, unfortunately the scaling up to 10x or 100x and printing with 1:10 or 1:100 did not resolved the issue. The preview window on mac is buggy, printing from sketchup on Mac will produce RANDOM results. I created the same drawing in another CAD on Mac and the drawing was printed without issue with the proper dimensions and I can split the drawing over several pages with proper dimensions. Unfortunately I am not able to do that with Sketchup. My trial period almost ended and I cannot imagine that I would notice such major bugs after I would buy Sketchup. For now my decision is not to buy Sketchup and I will try to evaluate other CAD applications. Thanks Anssi for your support, I appreciate it.


#5

I had what seems to be the same issue. I was trying to print to scale using a Mac with no luck. I turned off Vector printing option in the File/Print menu on sketchup and it solved it. If you do not see vector printing in your Print dialog box, click the Show details button. Hopefully this isn’t too late for you.


#6

I’m having the same or similar issue. Using SketchUp 2015 on a Mac printing 1:1 in parallel projection with vector printing turned off (the issue is even worse with vector printing turned on) and front view selected (as opposed to the top view as the previous poster reported). I’ve attached an image that is a composite of what I’m experiencing. The first image is the window as it exists when I select print. The second image is a screenshot from a PDF I took of the printed output - everything is stretched in the vertical axis. The third image is what the SketchUp window looks like when it returns from printing - everything is also stretched in the vertical axis. At this point SketchUp is unstable and I have to close the file. When I re-open it the viewpoint and zoom is all messed up, but when I zoom to extents all is well.


#7

Am having the same problem under the same conditions: SU15, MAC, OS X Yosemite, 1:1, Parallel projection, vector off. and using camera/standard views/top. Have tried a number of variations with no success. The most interesting aspect is that there seems to be a point where small changes in the screen zoom, cause significant changer, smaller or larger in the actual print, and do not allow you to “zero in” on a optimum zoom to print a fufu page ( have been using 8 1/2 X 11 as a test.

Do not remember similar problems when I printed with SU14 or when using tabloid sizing.

See no responses since Nov 14, Hope Trimble or the community has a Guru out there.


#8

i’m having the same problem. same conditions. i was finally able to get my drawing to print to scale, after many many restarts of sketchup.


#9

As a workaround, you might want to export your model as a PDF, making sure to select the appropriate 1:1 sale. You can then print the generated file using Preview or anything else that can open PDF’s. That has always worked for me.