Researching printing 1:1 scale from SketchUp Pro

I’m putting together a tutorial for how to print at 1:1 scale, directly from SketchUp Pro, spanning multiple pages. I’ve done a bunch of research at this point, but just want to throw this out there for feedback to make sure I understand all the quirks of printing to scale.

  • SketchUp will print the entire visible workspace, even if it’s “empty”. So the recommendation is to resize the SketchUp window to better fit the aspect ratio of the model area you want to print, then zoom to fill the workspace with the model. However, in the print dialog, there is a Use model extents checkbox, which one would assume would eliminate the necessity of having to manually resize the SketchUp window. From what I understand, this feature is buggy and does not work correctly, especially on smaller models, is this correct?
    image
  • When I have a certain printer (HP OfficeJet Pro) set as the active printer, the page size is empty and the scale dropdowns are empty. During my research, this is a known bug with no workaround?
    image
  • It’s my understanding that you can only print to scale when the camera is set to both parallel projection AND a standard view. Is there no way to print to scale using “align view” with a face that is not aligned to a standard view, even in parallel projection?

@DaveR especially interested in your thoughts if you have a minute. You seem to have beaten this topic to a pulp already. :wink:

Hey Matt. That looks mostly right. I’m not sure if the Use Model Extents is buggy or if it works as intended. Never gave it a lot of thought to be honest. I’ll send you some additional comments after I finish with my student.

d

1 Like

To my knowledge, this feature is not buggy. However, not all models report back with a useful “model extents.” For example, if a model contains a stray piece of geometry far from the rest of the model, or just far from the origin… the model extents (which will include this stray geometry in the calculation) will give results which might seem surprising. Or maybe ‘buggy.’

2 Likes

I mistakenly in a recent thread repeated what I had noticed about it years ago. It used to fail if the model was smaller than about 300 mm across and you tried to print to full scale. I can confirm that it now works in version 2020. I don’t know when it was fixed, not having needed such printouts for years. Sorry for the confusion.

1 Like

Thanks for the feedback John. I think I’m experiencing a different thing, though, or maybe I just don’t understand what “Use Model Extents” is supposed to do.

For example, I have this model, “Use model extents” is checked, (I have the model zoomed out on purpose in order to test that use model extents works as intended), but notice the page size is indicating 201"x112" (for reference, the corbel is about 30" tall), and when I print to pdf, I get 264 pages.


So it appears that even though I have Use model extents checked, it is still going by my viewport size.

But here’s the weird thing. If I try a second time, without changing any settings, the print dialog shows a different page size and number of pages (16). This time, the export seems to behave as expected. Seems like there’s a bug that’s not actually enabling the “Use Model Extents” unless it was already active from the last time.

image

Can you share the .skp file?

scaletestmodel.skp (360.8 KB)

I don’t understand why, if I open the print settings, and Use model extents is already on, I get one set of page size measurements, but if I turn it off, then on again, I get a different set of page size measurements. That doesn’t make sense to me.
image

Clearly the aspect ratio of the model window affects the number of pages. It is odd that there’s a different number depending on the use Of Model Extents or not although I suppose that could be influenced by the hidden components, too.

And of course with the model window shaped to fit the model closely…

To be honest Matt, I only ever do this stuff to show Make users how to print to scale. For my own use I wouldn’t bother printing from SU. I’d go to LayOut instead. I know that doesn’t help in your case, though.

Isn’t there value in printing direct from SketchUp for full scale models spanning multiple pages, in order to use as a stencil to cut out a board on a bandsaw or something? If you did that in LayOut, you’d have to manually align and crop each viewport on each page, seems like a lot more work…

1 Like

I would just set up a paper size to suit and set the viewport to show the entire model. Then I would export the PDF and use Adobe Reader’s poster print option.

It’s pretty trivial to make a multi page document for a pattern though. I’d only do that for a plan that also has other pages that need to be printed.

1 Like

Yup, that makes sense.

@DaveR I was thinking about this some more… I wonder, is it really easier to do it in LayOut? Do you have templates set up or something to make it faster?

So you take your SketchUp model > Send to LayOut > Set viewport size 1:1 > Scale viewport to see entire model > File\Document Setup to change paper size to fit viewport > File\Page Setup to change paper size to match so it prints to a single page > Print to PDF as single page > Open in Acrobat > File\Print > Set cut marks & labels > Print.

Shouldn’t it be easier to just from SketchUp, go to File\Print, set scale, and go? With either method, you still have to isolate what you want and set the camera, but if “Use model extents” worked as expected, you wouldn’t have to fiddle with resizing the window and it would be even easier. What am I missing here?

I suppose it might be simpler but I can create a nicer looking export from LayOut.

If I felt like I needed the index marks I could add them in SU with the model. I’d do that if I was multi-page printing from SU, too. Adobe Reader gives you an option to set an overlap percentage so depending on the model, you might not need index marks anyway. For a larger pattern I would likely increase the line scaling in LO and would rendering as Vector.

No screwing around with viewport aspect ratio, either.

1 Like

…and another thing. If I wanted to, I could send the PDF to Staples or someone for large format printing. Not likely you could send them a Sketchup file for printing.

As has been said earlier, Use Model Extents sizes the model to fit everything in the model into the window.

Very often, when I’m printing from SU at a fixed scale, I don’t want to print ‘everything in the model’, just what is in the viewing window.

So:

  1. Set a View/Standard View, usually Top, or Side, and Camera/Parallel projection.
  2. Adjust the window size in proportion to the paper you intend to print on. I have a big enough screen so that I can hold a piece of A4 paper (or one would use Letter or Legal size in the US) up to the screen, top left corner of the paper at the top left of the SU window, and resize the bottom right corner of the window so that the window and the paper are the same size. With a smaller size screen get the bottom right corner of the window on a diagonal drawn on the paper.
  3. Zoom Extents, then if necessary the Zoom tool (not the mouse scroll wheel, which zooms in jumps) to adjust the zoom so the model fits as tightly as possible in the window. Zoom extents typically leaves a small extra blank margin, so if the fit is tight, a slight zoom in may be needed.

You are now ready to print.

  1. Set the page orientation to the same as the window - Landscape or less commonly Portrait.
  2. Set the print scale to the scale you want. I commonly use 1:48 (1/4" to 1 ft), 1:50 if in metric, or 1:12, 1:8 or 1:1 (or their nearest metric equivalents). Ensure Fit to Page is unchecked.
  3. Click Print, or Print Preview, to check you will get what you expect, and make fine adjustments if needed to window proportions or zoom factor until it fits.

If you print direct to PDF, then when printing from that to paper, make sure to set the print scale to 100%. It usually (in my case) defaults to 97% or Fit to Page, which throws the printout off, and quite often by so little you don’t notice, until things won’t fit in reality!

One thing I haven’t solved is how to get a print from a model that would print on one A3 landscape page( US equivalent Tabloid, 11x17") to print on two portrait A4 pages direct from sketchup.

SU always tries to fit it on landscape A4 and takes four pages to output it.

I’ve had Layout for several years, but only recently set up a Layout solution for the last case.

Sometimes it’s touch and go whether my print will fit on A4, and then very fine adjustments may be needed to the window proportions, or the zoom factor, and it may take more than one try to get it all to fit on one page.

Actually, I don’t think this is how Use Model Extents is intended to work. When I’m able to get it to work, it actually ignores the modeling window. See my proof below: The SketchUp window is very wide, so you’re saying that if I printed it, I would also print all that white space. But it actually ignores the white space and prints it to 16 pages. (I would like to point out that the zoom extents should crop even tighter to the model, but it’s acceptable as is. )

The problem is, the checkbox doesn’t always work. There’s a bug. You have to try and print twice before the Use Model Extents actually works.

Thanks for the details observations. I’ll try it out here tomorrow - getting a bit late tonight in UK.

1 Like

Matt, I finally had time to do a quick set up in LayOut from the model. You can see how it would print with a quarter inch overlap.

1 Like

Yeah that’s a pretty cool feature in Acrobat.

1 Like