Cannot print to scale after reading many articles on this forum


#1

I want to print a drawing to scale 1:1 in Sketchup Pro. I have read several articles of other people having problems doing this. The only one that I have found that has succeeded is someone who repeatedly opened and closed sketchup. So how does one print a single drawing that is only 2d and is a rectangle 5 13/16" tall, 9 5/8" on the 3rd side and 5 13/16 inches on the 4th side on a single page? Why would this not be a program bug if one were to go to file->print then uncheck both fit to page off and model extents, set the correct orientation.and then click ok to print & not get the drawing printed correctly?

I have tried

  1. taking a screen shot, putting that in Microsoft Photodraw, and printing.
  2. filing my sketchup screen and then printing.with fit to page and model extents off.
  3. read several articles on this forum by people who are experiencing the same issue.
  4. gone through all the print dialog pages for my printer, a Epson WF-5690 and sketchup looking for scaling locations and not found any.
  5. printing with the Use high accuracy HLR both on and off.
  6. Googling although I will continue looking for an answer that works there.

As additional information, I exported the file as 2d model with a file type of dxf and that file is opened with SheetCAM about 10% too big. In the model extents, the scale (though grayed out) is not 1:1.

Are there any places where the model is scaled that I should check?

Anything else that I need to do?

Is there anything that I could have inadvertently clicked that might cause this issue?

thanks.


#2

Just in case Sage Geo’s world-renowned treatise on printing to scale was not among those you’ve read, here’s another link:

Geo’s Printing to Scale
[quote=“dwc309, post:1, topic:23532”]
So how does one print a single drawing that is only 2d and is a rectangle 5 13/16" tall,
[/quote]

One creates it in a 2D graphics program whose purpose is to produce highly formatted 2D output. It seems to me you’re in a locked-cage death match with SU, trying to get it to do something it wasn’t designed for, and it’s winning.

-Gully


#3

I’ve found that I need to shrink the SketchUp window down to completely frame my model … then the print settings seem to work like they should …


#4

Jim has given you a good answer. Resizing the window the proportions of the paper will get you there. Since you have SketchUp Pro, though, you could use LayOut. No need to resize the SketchUp window, It’s quick and easy to set up and you can create a PDF that anyone can print at the right scale.


#5

I did read Sage Geo’s treatise on printing. It’s what led to the question, “Why would this not be a program bug if one were to go to file->print then uncheck both fit to page off and model extents”.

And I did choose front in the standard view, resize the window, zoom to extents, and crop the drawing so that it filled the window. And I did try printing it to a both a pdf and my printer from this state and it didn’t work.

What I didn’t do was to do those camera steps. I did those just now and it printed 4 pages.

If I tried to set the page size in print dialog and checked fit to page and that didn’t work.

And yes it is winning. I can and will do these sorts of drawings in another program if that’s what it takes. It’s just that it’s a shame that what seems like a basic feature was left off what is an otherwise very, very nice program.

I’ll look at & try the other suggestions as well.

Thanks for all the help, forum.


#6

I don’t know that I understand “shrink the SketchUp window down to completely frame my model”. If I zoom to extents, the model fills the window which doesn’t work. If I put the dimensions on the drawing, they print correctly even though the drawing that was printed wasn’t accurate.

thanks for taking the time to make a nice reply.


#7

I’d like to add that if sketchup pro could print to scale and output a dxf file that is accurate, it would be possible to go directly from sketchup pro to a 3d printer, plasma cutter, or milling machine. It would greatly increase it’s usability.


#8

Fine, you can call it a bug, but I think that downplays the problem. If you ask me, SU’s control of printed output generally is a major catastrophe. It never has worked right, and has always forced you to do this weird rain dance to get it to work at all.

Between SU’s crude dimensioning and tolerancing ability, it’s lack of support for line weights and line conventions, and its inability to support graphic or symbolic drawing elements (such as weld symbols or Geometric tolerancing or machining finish marks) make it a highly undesirable tool for making 2D paper drawings. Why torture yourself?

-Gully


#9

I’m referring to the outside window for SketchUp … if you shrink the whole thing down to frame the model, it forces the extents to be smaller than the physical paper. When you go to print, it puts it on one sheet of paper to scale like it should.

I feel your pain … years ago, I gave up trying to print from SketchUp for the same reason. For some reason I started playing around with the overall window size and noticed that it printed just fine when I did this.


#10

I won’t torture myself (although I sometimes seem to inflict pain on myself without trying ). It’d be nice to be able to print or create an accurate dxf file for reasons I just added in a reply to your first post.


#11

Various users, myself among them, have identified all kinds of things that would be nice. There is a certain period where one is surprised and disappointed when the SU developers don’t immediately adopt one’s outstanding suggestions, and gradually, not immediately turns into not ever.

Eventually one reaches a state of resignation and even acceptance about SU’s shortcomings because it does what it chooses to do very well.

-Gully


#12

A quick skimming through this thread didn’t find a mention of the necessity of setting your camera to Parallel Projection to be able to print or export 2D images (PDF, EPS, DWG, DXF) to scale. Perspective has no scale.

Another thing: when your SketchUp model is “2D” so that all lies in the same plane, exporting it to DWG or DXF as a 3D model will not magically inject any 3D-ness into it. AutoCad stores all coordinates as 3D points, it has no separate “2D” format. The advantage of exporting a 3D model is that arcs and circles will export as corresponding CAD objects instead of being reduced to straight line segments as in the 2D exports.

Anssi


#13

That cleaned up the dxf file. thanks.


#14

Still had to export it as a 2d dxf file to get it to work. The 3d exporting wouldn’t work.


#15

As Anssi says, a perfectly accurate DXF export for CNC is entirely possible, I do it all the time. Make sure its DXF tho, not DWG. For some reason DWG exports curves as line segments.


#16

#17

Thanks. So if I do the following steps, I should be able to count on a 1:1 scale dxf file?

  1. Choose a standard view. Camera > Standard Views > Front.
  2. Choose parallel projection. Camera > Parallel Projection
  3. Zoom to extents. Camera > Zoom Extents
  4. Export as a 2D dxf file. File > Export > 2D graphic.
  5. Make sure that a dxf file output is chosen.

#18

Steps 1-3 still do not lead to a 1:1 scale print.


#19

as jimhami42 has already elaborated above, you need to shrink the program window to the model extents for avoiding the ‘white space’ around the model used for calculating the printing area by SU… a “Zoom Extents” is not sufficient.


#20

I was finally able to get an accurate print by changing the scale to 1:1 in the Print dialog.

The steps should then be I guess

  1. Choose a standard view. Camera > Standard Views > Front.
  2. Choose parallel projection. Camera > Parallel Projection
  3. Zoom to extents. Camera > Zoom Extents
  4. If saving for milling or plasma cutting
    a. Export as a 2D dxf file. File > Export > 2D graphic.
    b. Make sure that a dxf file output is chosen.List item
  5. If printing,
    a. click print
    b. In the print dialog box in the Print Size area,
    i. uncheck Fit to page & use model extents
    ii. ensure that the Page size is greater than the model size.
    iii. Under scale make sure that it is 1:1

So printing and saving for cnc equipment is doable. It is cumbersome. Many spotted owls gave their lives in achieving this result but many more will be saved in the future.

Once again, thanks to everyone who helped by making suggestions.