Print to scale produces wrong printout and causes problems in view

bug
export

#1

Trying to print a document to 1:1 scale on a MacBook using Print > Save as PDF (or Open in Preview) both fails to produce the image expected from the print dialog preview and messes up the view in SketchUp. This video demonstrates the problem:

I’ve tried in SketchUp Make 16.0.19913, 15.3.329, and 13.0.4123 and get the same effect.

I can successfully produce a 1:1 scale printout if I print from SketchUp 8.0.11751, 7.1.6859, or 6.4.245 (after exporting to the appropriate older version). Those older versions exhibit some rendering issues, too, but they’re not nearly as severe and do not prevent me printing the scale templates I need.


#2

your video is Private…

are you using ‘Parallel Projection’? print to scale only works in a Standard View with PP set…

john


#3

The video should be public now.

I am using parallel projection. The issue is that SketchUp alters the view after print preview but before printing in a way that both messes up the printout and does very strange things to the model view afterwards, such that it is neither parallel projection nor perspective.


#4

This is something for which LayOut is perfectly suited.


#5

printing is an US$800 “feature”?


#6

That’s not what I was implying. But if you need to print to scale, LayOut makes it very easy.


#7

I am reporting a bug in SketchUp. I would like to discuss that bug, if that’s OK.


#8

Sure. That’s fine. I just tried printing a PDF to scale out of SketchUp but didn’t find any of the behavior you describe.


#9

There is no such thing. Can you post an example?
Have you “Use Model Extents” checked in your Print dialog? that would make the printout different from what is visible on your screen.


#10

Please watch the video I posted that covers all of this.


#11

Thank you for testing


#12

Works just fine for me on my MacBookPro Retina. Not sure what is going on with yours…


#13

That’s my machine, too. Thanks for checking.


#14

I couldn’t see if “Use model extents” was checked or not in your video. SketchUp has an old, old bug where printing small objects (about 1 feet across) to full scale results in the printout spreading across multiple pages if the “Use model extents” box is checked. The workaround is to either scale up your model by 10, for instance, and then print to 1:10 scale, or, to uncheck the box and resize your Sketchup window so that the items to be printed fill it. The bug dates back to as far as I can remember (started using SU at version 3).

Anssi


#15

Thanks for the suggestion, Anssi. I can’t find any sign of a “Use model extents” checkbox on the Mac version of SketchUp. In the course of searching for it, though, I came across this thread that I didn’t find earlier. Seems to be a very similar situation to mine experienced by at least a couple of people.

Unfortunately, scaling up and printing at 1:10 scale doesn’t help. Neither does unchecking “Vector Printing”; in fact, the printout comes out worse than before with a bad aspect ratio and the model view is similarly distorted afterwards

but

if I uncheck “Vector Printing” and Save to PDF, then recheck “Vector Printing” and Save to PDF again, then the scale and aspect ratio appear to be good in the PDF. The screen display is still distorted, though, and the weird zooming behavior remains.

Still, it’s some kind of workaround that doesn’t involve exporting to an ancient version (which had its own problems).


#16

guyer;
When you are printing to scale you are actually printing the total screen image. SU communicates with the printer and knows what it settings / capability are. It also knows the model size and can then determine the screen size in real world dimension and if that is bigger then the printer format size it will do a tile print and you will have multiple page print out. Some of the quick screen shots appear to show that artifact. Try a actual print with the fit to page ( non PDF) selected and see what you get. Even if you try and zoom to model to fit the screen , that success will depend on aspect ratio of the two , and there are still allowances for tool bars. Those can even be actually measured.
I have noticed cases where the tile print you see on the screen is not same as actual printer output and is reason for actual print suggested above. I do not have Su2016 loaded so can not compare my test cases in it even if I find them.
SU does not have a vertical / horizontal centering algorithm so the tiled print outs can be shifted as you are seeing.
This not new issue and selling point for PRO version.


#17

Thanks for your observations. My issue is not with the unpredictable tiling (although that’s annoying); the problem is that the printout is not 1:1, often not even retaining a proper aspect ratio, and the model view outside of the dialog is somehow corrupted by the process of trying to print 1:1. You can actually watch the model view shift and become “broken” while in the Print dialog when you click Print or even switch pages in the preview.


#18

do you set it before you start, in the video it seems like you haven’t…

the SU viewport needs to have a 1:1.294 aspect ratio to match the printers ‘Letter’ paper ratio…

draw your page to it’s correct size, delete the face, and draw you shape inside that boundaries

then, when you ‘Zoom Extents’ the viewport includes a ‘safe margin’ so needs a ‘new zoom’ set at approx. 1.052

Sketchup.active_model.active_view.zoom_extents.zoom(1.052)

the Printer needs to be set for ‘Margin-less’ printing
then
Top View >> PP >> Zoom Extents + newZoom >> Export >> 2d >> PDF >> Match View Size
will produce accurate results…


#19

What do you print to? How do you check?
You must use one of the standard views and a Parallel Projection camera.
Do you print to PDF before printing to paper? In the latter case, the default setting in Adobe Viewer or Acrobat is “Fit to paper” that adds additional margins - you should select “No page scaling” instead.

Anssi


#20

@Anssi, he’s on a mac and the built in PDF, honours the removal of margins if done in SU, as a new zoom…

@guyer, alternatively if the ‘dummy page’ is scaled down by 0.9507, you can avoid the need for the ruby code…

after ZoomExtents you could hide that edge to not show in the print…

john