Exporting 2D from sketchupmake


#1

Hi there
I’m trying to create accurate PDF exports in 2D. Its was working (in perspective) earlier but something has changed and the greyed out under Image scale won’t allow me to get 1:1.
I think the resulting PDF is now too big and perhaps my image too small to see.
I’ve since tried swapping to parallel but it still won’t work.
HELP PLEASE


#2

Camera menu has to be set to “Parallel Projection” (Not “Perspective”)
-and-
“Match View Size” must be un-checked
-in order to set scale

Checked/scale greyed
48%20PM

Unchecked/scale set
08%20PM

On a Mac, you can also print to PDF if you want.


#3

Thanks RT
But it was working fine all morning in perspective - is that a lucky accident perhaps?
I’ve tried swapping to parallel from the camera menu, but this won’t work either.

I’ve always found the print to PDF a bit more clumsy(in terms of getting the image centred correctly )- can this be fixed?


#4

I’m on 2018 Pro, if that matters, but I’m not finding the ability to scale in perspective view. My memory is a bit foggy on whether it used to be able to in any previous versions.

For printing, you have to go through page setup and document set up with mostly the same settings, so I’m not sure it matters much which way you go.

Here’s document setup with perspective on, it it outright tells you you can’t use scale.
20%20AM

I’m not sure what you were experiencing. Anyone else?


#5

Unfortunately the print dialog box can only do so much for you. I assume you’ve taken a look at LayOut? I know your question is about Make but LayOut is really great once you learn it and if you find yourself annotating, dimensioning, printing, scaling, or presenting a lot of SketchUp model views, then it’s really the best way to go.


#6

thanks
yeah, Ive got a sinking feeling that’s the way I’m going to have to go


#7

Well if you have questions let us know. There are a few other LayOut pros on here that are pretty quick to respond.


#8

As @RTCool points out, Perspective and Scale are mutually exclusive.

Camera must be set to Parallel Projection and one of the Standard Views

It helps to adjust the aspect ratio of the viewport to the same aspect ratio of the desired output.
Here’s a handy plug in for that.

Safe Frames by SketchUp Team
This extension lets you set the aspect ratio of the viewport on a Mac.
https://extensions.sketchup.com/en/content/safe-frames


#9

Thanks @Geo, I knew I had heard of that extension, but forgot what it was called or where to find it.