Print to scale produces wrong printout and causes problems in view

bug
export

#21

I was referring to the aspect ratio of objects in the printout and in the model: squares are no longer squares, circles are squashed, etc. I want to stress that not only the printout isn’t what’s previewed, but the model view is distorted after printing. Zooming doesn’t work right and if the model is visible at all, it is distorted.

However, your description was very helpful. If I draw a rectangle representing the page, as you describe and then resize the window to just include this page, then the printout seems to match the preview and the model view is not corrupted afterwards. As clumsy as these steps are [*], it’s a huge improvement over what I’ve had to do so far. Thank you!

There is still clearly a bug that leads to the corruption of the view if the printout needs to be tiled onto multiple pages, but I at least know how to avoid that situation now.

[*] Zoom extents doesn’t work in my case because I have multiple scenes located in different places in space and zoom extents seems to want to include the origin, regardless of where visible objects are in space.


#22

I print to a PDF. I’ve sent the PDFs to a variety of printers; doesn’t seem to matter what they are.

The PDFs are manifestly distorted, but also readily confirmed by using Mac OS Preview.app to measure various items in the view.

Yep. Parallel Projection, Front view.

That doesn’t seem to be a problem in Preview.app. I’ve been able to print 1:1 scaling without any additional margins or “fit to paper” going on.


#23

guyer;
Take a close look at doc set up and you will note it is showing 2 pages for the print and is what I would expect and is what SU is calculating with your set up.
The EADID ( Extended Display Identification Data ) Information to PC ( Yes I can read know you have mac) gives the native resolution data and that with the image size allows calculation of dimensions to print and is exceeding the format size of your printer thus the tiling. You are correct trying to zoom your model to screen size but will fall short with your setup.
I normally do not use that option, but if needed for say trying to make template I’ll use the info SU is providing, use image program to scale then tile print from there so I have some thing decent to " glue" together to make it.
Other wise I would use some one who has a large format printer.
You can simply make image of your screen at size you are trying to print , open that in image editor like GIMP which then gives you the capability to make size measurement and see what the actual size is you are trying to print.
BTW in you video when you chaNge scale 1;1 not the print size is showing 14 35/64 w X 7 49/64 h I WONDER WHAY IT IS SHOWING THAT ???


#24

I know this is an older thread, wondering if anyone can still see this behavior? I came across the very same problem recently and so far have only been able to reproduce it on one Mac that is running OS 10.10.5

While glad to see that others haven’t run into this, curious if it comes up again.


#25

Here it is late 2018 and I’m reviving this topic, having the same problem using Sketchup Make 2016. I’m using a 2015 Macbook pro with AMD Radeon R9 M370X 2048 MB Intel Iris Pro 1536 MB.

I don’t have problems as long I avoid vector printing. I’d like to use the vector printing because the dimension fonts come out to a useful size.

edit: I was wrong about avoiding vector printing. It doesn’t matter. Any scale printing will result in the strange behavior.


#26

I am not a Mac user but I understand that since SketchUp 2016 was released Apple has introduced new OS versions that have messed things up in SketchUp. New SketchUp releases have then tried to fix things, like the latest maintenance release to version 2018 Pro that was released this month and fixes compatibility issues with MacOS Mojave.


#27

Thanks for the reply Anssi. The latest Mac OS version I have now with it’s Safari browser seems to have messed up gmail and youtube so I can’t see some of the controls and input fields, so I don’t doubt that Sketchup got messed with as well. I’m using the trial version of Sketchup Pro right now. I tried Layout and it works just fine for printing to scale. I’ll just have to decide if my need there justifies the price tag for a pro license, and if I should get a Windows version to make sure everything actually works when I want to print straight from Sketchup.


#28

@Anssi is correct: in each of the last few upgrades of macOS, Apple has changed something that affects versions of SketchUp that were released prior to the macOS upgrade. The consequences range from outright crashes to soft failures of specific features. You might not see any effect unless you use the specific feature and then one day poof!

Trimble only rarely releases mid-year updates of SketchUp in case of egregious or fatal bugs. In this case, there was an update (18.1.1180) specifically directed to issues with macOS 10.14 Mojave and Layout in particular.


#29

I’ve discovered that the problem has something to do with printing to scale that requires more than one page. If the window will fit on one page, everything is fine. If the window is made bigger and will require two or more pages to print, then everything goes bonkers. I made a short video to show it - no sound: https://www.youtube.com/watch?v=UoqVSK86WmE