Scale printing using multiple pages


#1

I have a small 6" x 9" template that I would like to print in scale. It should have no problems fitting on a single piece of 8.5" x 11" standard printing paper. I cannot for the life of me get this to print on only 1 page.

I have looked over other posts and forums. I have the component selected. Im fully zoomed into the piece. Im also printing in landscape mode.

I fiddled with the zoom and ONE TIME (out of hundreds) the preview had the template all on one page. I canceled the preview and went to print it…and it printed 6 pages with the template split on 2 (as if I had a bunch of empty space in the view. I should have printed it while in the preview…)

After more fiddling I was able to get it onto 2 sheets of 8.5x11 in the print preview. Most of it was on 1 page with only a little piece on the second. I have some 8.5x14 paper and thought that should do the trick. I adjusted the print setting for the new paper size. The preview has an identical image, just with more white space on either side?

How can I get this to print on 1 page? Why is this to finicky? Does SketchUp hate me? lol jk :stuck_out_tongue_winking_eye:

I appreciate any help or advice anyone can provide. Thanks in advance!


#2

One thing you don’t mention is the aspect ratio of your SketchUp view window when you invoke print. If the aspect ratio isn’t close to that of the target paper, SketchUp may split the print over multiple pages.


#3

It’s probably as Steve suggests that you haven’t set the aspect ratio of the drawing window correctly.

On the other hand, it could be that “asdf” graphics card you listed. They are well-known to be unsuitable for SketchUp.


#4

I created a 9" x 6" rectangle and reduced the window size to have narrow borders around the rectangle. The printer settings for landscape mode are:

Using a 6" x 9" rectangle and portrait orientation:

Having too much of a border around the rectangle will result in spreading the print across multiple pages.


Not possible to print a dead-simple figure in real size if not a professional? (answer: margins and window-fit)
#5

Some times I have the same thought
The display communicate its display capability to the pc.( See EDID extended display identification data). What you really print is the image displayed on the screen. There are margins allocated including those for tool bars ( windows and SU) ( in pixel dimensions) , print margins based on printer etc. plus Su knows the model size. So you may see cases where you will get " tiled" prints even though the model does not fill the full screen. Unfortunately Su free does not have a centering algorithm so some “tile” printing happens even when it is not expected.
Pay attention to the print preview screen and tiled sheet print range to make sure you have only the 1 page


#6

Actually the printing directly from SU is and has been for too long pretty clumsy - its the only software I know where you have to adjust your viewport proportions to get an efficient print.

I know that doesn’t help but at least your not alone


#7

SketchUp has the “Use model extents” box that you can check but it only works if the model is substantially larger than your sheet of paper and you are not printing to full scale. A workaround for small models would be to model them at,say 10 to 1 (for instance, use Centimeters instead of Millimeters) and then use a scale (in this case 1:10) to print it.

Anssi


#8

Actually, I rarely print anymore from SU, I mostly use Windows “Snipping Tool” to grab a screen capture and email either directly to clients or send to my Galaxy Note 12.2, and sketch amendments / notes / ideas over the capture in Sketchbook.

We virtually have a paperless office here

If doing formal documents for clients then printed sheets are setup via LAYOUT and issued as PDF’s


#9

lol, I updated my graphics info. Its an AMD Radeon R9 360.

Im going to have to do a face palm here and ask where I modify the aspect ratio? I did a brief google search and nothing jumped out. Are you referring to a setting within SU or would this be a system display setting?

I really appreciate all the movement on this thread. :blush:


#10

Just drag the edge of the SketchUp window. It’s like resizing any other window on screen.


#11

a screen shot of the print preview:


#12

And of my SU screen:


#13

So do what you were told to do. Make the drawing window narrower by dragging its right side over so it is closer to the model.


#14

same…


#15


#16

Could you just share the SKP file?


#17

Gladly. Attachedsu-issue.skp (21.2 KB)


#18

The problem you’re having is created by what you didn’t show us. Hide the other parts of the boxes in your model space so the only thing you have showing is the box side and the dimensions. Make the window aspect ratio close to that of the side and its dimensions.




#19

That did the trick.

Thanks Dave, I really appreciate your help.


#20

Followup for posterity:

Following the above steps and printing with xps doc writer did not give me a scale printout. The 9" was long, measuring in at 9.25.

Doing a direct print from SU also yielded a print not to scale - The 9" length was short at just over 8.625"

Enabling ‘Use model extents’ at 1:1 did the trick but did print 2 extra, blank pages.

And now as I try to recreate the scale print, im getting the same issue… all other components are hidden. aspect ratio is shrunk down…print preview keeps pulling up with 2 - 6 pages with the image split between two.

I think im going to call it a Sunday…

Your prior efforts are still much appreciated Dave. TY