Printing to fit page


#1

SketchUp is a really user friendly program. I’ve used it to create some drawings of some projects I have in mind for my wood shop. The big problem I have run up against is printing the designs that I have created in a large enough format for me to use in my shop. I try to print my design and it is simply too small and shows up as just a little picture in the middle of a big page. I haven’t been able to solve this problem and so I’ve been spending some time looking for a different CAD program. Most of what I found are difficult programs to use and learn. It would be much simpler to simply find a way to use SketchUp to do what I need. Is there a way to print from SketchUp with my pictures coming out large enough to use?


Not possible to print a dead-simple figure in real size if not a professional? (answer: margins and window-fit)
#2

have you set up your Printer?
click here >> Printer SetUp <<


#3

If you use it commercially, you have PRO and should have a look at Layout for this task too.


#4

Not using Pro. Just making a few drawings for my hobby shop projects.


#5

Ok, so I played around with the print setup options and guess what? It worked. Now, why couldn’t I do that without asking? Anyway, I find the numbers on page size really wierd. I had already chosen “Fit to page”, but what made it work was to uncheck the “use extants” box. Printed out fine. Thanks!


#6

Printing to Scale — SketchUp Sage Site


#7

You can create two scenes, one for modeling and another with a print view (and activate Scene Tabs on the View menu, to switch easily between them.)

Usually they are used for camera animations, but we can uncheck the “include in animation” box, [in the Scene Manager,] and use them for certain viewports into the model.

You can even have a layer that contains a section plane, only visible on a certain scene view.

So set up a scene page named “Print” just the way you like it, and only switch to it before printing. (Make sure to “update” this scene after it’s set the way you want it.)

You don’t need to worry then how you leave the “Model” scene page camera, ie, zoomed way out, zoomed way in on some small detail, etc.)

ADD: Consider creating a template for yourself when you get the model environment setup the way you like.


#8

Printing from SketchUp has a known bug (it has been there all the time I have used SU from v3) where printing smaller objects than about a foot/300 mm across to full scale will add margins to spread the print across multiple pages even when the object is small enough to fit on a single page, if the “Use model extents” box is checked. If you scale the model up by, say, 10x and print to 1:10 scale, it works fine.

Anssi


#9

As I mentioned above, you can create a template with preset scene pages for printing, thumbnail and modeling work.

Attached is an example SketchUp 2015 template with these 3 scenes, each of which has it’s own Style of the same name. (ie, “Print” scene has the “Print Style” set as it’s style. etc.)

Work-Print-Thumbnail Pages.skp (24.6 KB)


Can I set a different style to the global style for a selected object
#10

Thanks, guys. That helped and I now have it working. @DanRathbun, I’m going to try what you suggested. Sounds like a good way to make the program work for me.

Thanks again, everyone.


#11

I’m pretty sure this is a Sketchup bug, as Fit View To Page in the Document Setup has never worked. My workaround is to leave Fit To View unchecked in the Document Setup, and change the smallest dimension to either 8" or 10.5", depending on whether you are printing, correspondingly, in landscape or portrait orientation. The larger dimension will scale proportionally up to 20" or so, but don’t worry about that. This setting will now fill an 8.5 x 11 inch page with 1/4" margins. For narrow Sketchup models, you’ll need to pan the model to the left side of the screen and use Portrait orientation. When you print, select only page one to print, otherwise, you’ll end up with a lot of extra blank pages. You’ll also need to increase your dimensions’ font size to 30 points or so, as another bug seems to prevent the dimensions from scaling up.


#12

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.