Sketchup won't print image correct size

Drawing is a series of boxes, 6" tall and 12’ long. Dimensions are inside the boxes.

When I try to print it the printer dialog boxes give me a really strange page size (like 19" by 3" to six decimals) and won’t let me change the size. Printer is set to correct size but print preview shows the image as a very small drawing in the middle of a page and often tries to put it on two pages.

I exported it to Photoshop and printed it but printing in SU would be much prefered.

I just downloaded the new free version – do I need to delete old version?

Other drawings print correctly, just this one is acting up.

Hello @jmcaldwell

SketchUp won’t print to scale unless the camera is in Parallel Projection mode.
You screenshot indicates the camera is in Perspective mode.

More tips here…
Printing to Scale — SketchUp Sage Site

1 Like

How do you figure that out, Geo? It says Front in the top left. I thought that only appeared in parallel projection?

[EDIT]
Apparently not so - if I change to Parallel projection, then select the Front view and change back to Perspective, it still shows Front in the top left, so i’m wrong in my belief.

changed it and still no luck. Not trying to print to scale, just to print like other files. It’s the free version.

Here’s what I get. Printer still tries to tell me the page size is something like 25 x 13

Can you upload the model to see if it behaves the same way on another computer?

I’ll try.

oops – I only have a .skb file and we can only upload .skp. Here’s .jpg. Is there anything else I can do to get you the file?

Because despite it showing the view as Front, the green axis is visible. It wouldn’t be if the camera was set to Parallel Projection.

In order to get your model to cover as much of the paper as possible, use Zoom Extents to make the model fill the drawing space and adjust the window proportions so they are close to the shape of the paper. Set

1 Like

I’ve zoomed it until it goes off the pages and it still shows up small.

Printer is a Canon Pro 10 (13x19 capable but loaded with letter size right now.)

Rename it to .skp (perhaps under a different name, too, so you don’t lose the original skb), then upload.

I see now. Missed it first time, thinking the Front indicated parallel projection.

There should be an SKP file, too.

need to clean glasses and monitor. Here’s the file. Good luck

windo sill cut sheet2.skp (182.7 KB)

As I said, make the drawing window closer to the proportions of the paper. I narrowed up the window as you can see.This is set up to print on 8-1/2 x 11 paper.


It looks like you’ve gone to a whole lot of work you probably didn’t need to for what you’re doing.

By the way, if you move those labels in, you can get an even better fit.
Screenshot - 12_15_2017 , 7_25_02 PM
Screenshot - 12_15_2017 , 7_24_31 PM

Here’s what it’s doing now.

It’s a “cut sheet” showing how to cut the most pieces out of some 12’ boards.

It’s also still giving me strange page sizes.

This started after I upgraded to the new version. Could that be part of the problem?

Did you narrow up the model window like I said to do?

What size pages?

Not likely. I made the screen shots, above, in SU2018. It works exactly as it always has for this sort of thing.

BTW, it’s a heckuva lot easier to do this sort of thing in LayOut.

10.669 x 4.978

yes, and the second time I tried it the correct image came up.

Guess that’s the workaround for not having a “set print area” option.

Don’t have LO, just the Free version of SU

Thanks for the help.

More questions later :wink:

I don’t know that it’s a work around. The print area has always been based on the model window and it’s aspect ratio.

So then you have to work with it the way it’s designed to work. If you have to do much of this and your time is worth anything, SketchUp Pro would be a good investment to get LO. And of course if this is for something other than personal hobby use you would need Pro anyhow.

Use this plugin to set the SU viewport to the same aspect ratio of the paper.
Eneroth Viewport Resizer — Extension Warehouse

Great extension for PRO. Can’t afford pro yet. :frowning:

The author, @eneroth3, states on the Extension Warehouse page
The plugin works with either SketchUp Make or Pro for Windows OS only.

1 Like