Issue with printing


#1

I am trying to print something to scale but I am having several issues.

I have already:

set camera to parallel projection

ctr+shift+e

My issues:

No matter which camera view I choose it is always wrong. However not using any of these and it looks fine, so I’m not really sure if that is an issue or if this is what is causing my next issue. Here is a screenshot I have before I try to change any camera views. Using any of the others throws the camera way off and even messes up my model. http://imgur.com/a/cB7Q6

I need to print to scale but the drop down boxes are empty. Here is a screenshot http://imgur.com/a/ES6UA

And finally, sketchup does not seem to be recognizing my printer at all, a kodak esp 3250


#2

What do you mean? What exactly is wrong?

How about uploading the images directly so we can see them without going to imgur? Upload the SKP file, too, so we can it and help you get it sorted out.

And please fill out your profile with useful information. Which version of SketchUp Make are you using? Which Windows version? What graphics card? Try to make it easy for us to help you.


#3

What do you mean? What exactly is wrong?

It goes back to non-white background, but it also moves everything around. Here is an image after I tried camera > right

How about uploading the images directly so we can see them without going to imgur? Upload the SKP file, too, so we can it and help you get it sorted out.

Sure. print sheet.skp (130.0 KB)

here are the imgur images

And please fill out your profile with useful information. Which version of SketchUp Make are you using? Which Windows version? What graphics card?

I’m not sure which graphics card I have, its an ASUS laptop from just over a year ago. I’m also using windows 10

But I have SketchupMake 16.1.1449


#4

You have the parts scattered all over the place.

And you have them set up so a view of their faces (what I would normally set up as either a front or top view is aligned with the right view. In the front view, the red axis should run left to right and the blue axis up.

You’ve modified the style but if you want a white background, you should edit the background color and turn off the ground. The style is entirely withiin your control.

If you put all the patterns in the same plane and arrange them so they are close together, it’ll be easier to make the layout the way you want it. Here I’ve arranged them so the Front view should work for you.
print sheet.skp (129.8 KB)

As for why your printer settings are blank, does the printer show up in the Print window at all? Is it set as your default printer in the print settings?


#5

For future reference Why aren’t they scattered in that picture I posted?

Thank you, I fixed that. I thought I had before but that was the ground I changed.

How the heck did everything get out of plane? I literally pasted all of my components onto a big square then deleted the square afterwards? The only thing besides that I did was flip a copy of that one leaf along the axis. If everything is all over the place why does it look right in my image I originally posted?

Its not showing up in the drop down boxes in print setup or print preview.

Also my actual issue I came here for I still don’t know, why the drop down boxes in scale are empty. I had already printed to a pdf just fine even with all the issues you talked about, i just couldn’t get it to scale. I also just tried again with the file you posted and the drop down boxes are still empty. If I have to just print to pdf then print that is fine, but it needs to be scaled right in the pdf.

Thanks, sorry this is such a pain


#6

It’s a point of view thing. With the camera set to Parallel Projection and the camera position you had set, they wouldn’t appear to be out of plane.

Yes. And with the ground set to transparent, you can see up through it when you get the camera below the ground plane (red-green plane) but it would make things look a bit hazy.

I have no idea but they were out of plane. How was the bit square oriented? Where did you paste the components from?

I don’t understand why your printer isn’t showing in the drop down menu. How does it show in the Windows Printer settings?

FWIW, if you need to print things like this on a regular basis and the scale is critical, it would save you a great deal of trouble and time to use SU Pro and LayOut. It is specifically designed to do this kind of thing easily.


#7

I drew a rectangle along the green axis then lifted it up, then I pasted the components in one at a time(I previously made the components the same way and save-as’d them to their own files)

I figured it out. I had never tried to print anything on this computer and hadn’t realized windows10 did not have drivers for the printer. Once I downloaded and installed them it is noticing the printer AND the scale boxes are no longer empty.

Although I don’t understand why the scale dropdown boxes were empty until I installed printer drivers. My endgame is to actually make a pdf but I wanted to print to test first. But things seem to be ok now.

Thank you for your help Dave


#8

It’s best to keep your model close to the origin.

So you drew a rectangle aligned with the green and blue axes and ostensibly used that to locate your components? That would explain why the standard views didn’t work as you expected.

Since the Face Style is set to Wireframe, it would be easy to wind up with the results you show. For this model and just printing these out, you could just as easily have laid everything out on the ground plane. That is, the red-green plane. SketchUp would naturally just want to place things on the ground plane if you are looking down on it at all.

Well, that would definitely explain it. That answered the last question in my second post.

They rely on the print driver for the current printer. They are affecting printer settings.

Glad you got is sorted out. Maybe you can mark the thread solved.


#9

Why would it need printer drivers to scale for saving to a PDF?

Also I don’t see an option to mark as solved, so I just edited the title.

Thanks again for the help


#10

On the bottom of the post you feel has solved your problem, next to to loveheart is a tick.
Click that.


#11

Not mine! It should be one of DaveR 's.
He did all the work!

Remove the solution from my post please and put it on one of DaveR 's posts. It’s rightfully his.