Model disappeared after SketchUp stopped


#1

Hi,
I worked on a model and i wanted to make rendering with Maxwell plug-in. File was a bit heavy so like it can happen sometimes, Sketchup stopped to work and closed (i was just rotating the model at this moment). But since this moment, my model disappeared, when i open it, only the grey background… And axes disappeared too…
I click everywhere and i see in “entity infos” that i can select lines, groups and all things. So model is still here but invisible. And if i draw something, the same, it’s here, but invisible…
I tried to export it in an other file but it doesn’t work.

A solution to save some days of work?

I join the file here to take a look : http://www.filedropper.com/house_1


Camera Position
My whole model disappeared/the screen is blank...?
No axis lines appear at launch
#2

Hello. There was someone else having the exact same problem some time before. I’m having trouble finding the exact topic here on the Forum. If memory serves me right, I think they fixed it with a plugin. I’ll let you know, when I find it.


#3

Hello again. I managed to recover your file (more or less). I think you had some textures but I was unable to bring them back, so sorry for that. Here’s the file: House Recovered 2016.zip (2.3 MB)

I also found the topic which had the same problem you were facing: Strange Issue with a Disappearing SketchUp File


#4

Yes, this model suffers the same issue as discussed in the topic @VahePogossian referenced: there is a component instance placed at an astronomical distance from the model origin and the view’s camera has consequently also had its eye moved beyond the fringes of the solar system so that everything is too small to see! I’ll see if I can repair the model without losing anything…


#5

Here is my version of the repaired model.

As a side issue, you are not using SketchUp’s layers safely. You have the Cloisons layer active and have a considerable number of edges and faces associated to layers other than layer0. I don’t think these aspects are related to your model’s ultimate issue, but I fixed them anyway.

Then I used some personal Ruby scripts to find the offending component instance and relocate it arbitrarily to a point somewhere near the origin but outside the house, as I don’t know where it was meant to be. You can see it selected in the attached screenshot and maybe put it where it was supposed to go or find the missing piece in the model and repair it. There are lots of additional instances of the same component in the model, so I suspect it is something like a roof tile.

House-2.skp.zip (2.2 MB)

Edit: here’s where I think it belonged


#6

Wow, good job @slbaumgartner! And you managed to bring back the textures as well! :slight_smile: :thumbsup:


#7

Oh! It’s really perfect! I even didn’t expect that. A big thank you! For both of you!
I guessed it was a component located very far from the model, but i didn’t know how to fix it… Thank you again!


#8

Hi slmaumgartner

Wonder if you can take a look at my model if I upload it? Seems to have the same problem - but I don’t know how to delete any stray edges nor to adjust camera - I have a feeling this is a problem that is going to recur, so would be great to know how to solve it in future myself as well.

Thanks

Eric


#9

I’d be happy to take a look. If your model is <3MB you can upload the file directly here using the button at the top of the reply window or by dragging it into the reply window. If it is larger than 3MB you will need to load it to a file sharing site or the 3D Warehouse and post the link here (make sure it is publicly accessible).


#10

Brill thanksFloors & roofs v3 (problem case).skp (364.4 KB)

As you can see, it’s not a complicated file…


#11

There is also this one if you can have a go with it as well?Floors & roofs v2.skp (388.0 KB)


#12

Working on the first one. So far I’ve found several Text entities that point to never-never land, hence make zoom impossible. Still hunting for more, as that didn’t heal it completely.

Later: There were a lot of texts in that model. Somehow they were fouling SketchUp’s management of the camera. I deleted all of them and this is what resulted (which will now zoom cleanly). I am coming to suspect that some aspect of manipulating texts when the model contents are 2D is causing the problem.

Floors & roofs v3 (problem case).skp (370.9 KB)


#13

Your issues definitely tie to some aspect of your use of texts. Here’s what I see if I carefully zoom out the v2 model using the mouse

Texts are strange beasts. They are actually fixed and sized to the view screen, but they have a “leader” over to a point on the model. I’m digging deeper into them to see whether yours have peculiar values in the leaders. Maybe when you have all the model contents on a single 2D plane and add Texts, sometimes SketchUp gets confused about where the leaders should go. Stay tuned…


#14

OK well done for finding the issue - you know I do find that when labeling an area, that the text can move position when you add or subtract a line here or there. For example once I deleted a line and a bit of text (pretty sure it was related to an adjacent space) disappeared at the same time. I didn’t think anything of it because in fact I wanted to delete that text anyway, but looks like that’s the mechanism for text to disappear into oblivion. I think if you relate the text directly to a line or object and not on a face, that this will resolve the issue.


#15

A piece of advice that may help preserve your sanity in the future: I see that you have SketchUp Pro. Annotation such as this is really what Layout is for. You should create scenes each showing one of the floorplans in parallel projection top view, create a Layout file with a page for each of those scenes, and add your annotation there. That way you avoid cramming all the texts for all the separate floorplans into a single SketchUp view, which may be somehow contributing to the singularity hitting the camera.


#16

Hmm, yes OK will have a go. Thing is, I use SU to annotate only for my own benefit as I get my head around the house and its construction, and getting the elevations right requires everything to be on the same page.

Btw would you be able to do the same text deleting venture on v2 for me? Version 2 was (bizarrely) the more updated version I was working on (although v3 seems pretty similar).

Thanks for all the help


#17

Here you are:

Floors & roofs v2.skp (355.3 KB)

In looking closely at this model, I found 5 texts whose positions were undefined and 76 that were located on the red-green plane but had their leader pointing off the plane. I suspect that what is happening is that as you add those texts SketchUp is getting confused about the z depth you want the texts at and what they are supposed to point to (it is fundamentally a 3D modeler even if you are working only at z=0). Later that causes view disasters when it tries to cope with texts that don’t actually point at anything.

Please understand, I think this reveals a bug in SketchUp. Even if you do what you are doing, it should not blow up!


#18

you can minimise the likelihood of disaster by using height for the text, rather than pts

also, group all your text and add it’s own Layer, so you can turn it off if needed…

john


Crash and blank screen | URGENT |
#19

Great, thanks so much.


#20

Thanks for the tip - could you just take me step by step how I actually go about both of those actions?