Model disappeared after SketchUp stopped

I tried John’s idea, and it is actually sufficient just to put all the texts onto a layer (or several layers) and then hide that layer(s). Zoom works fine when the texts aren’t visible. This supports my claim that the problem is in SketchUp’s handling of the view when the texts get messed up coordinates. If it doesn’t have to display them, SketchUp doesn’t care!

a quick gif…


1 Like

OK brill thanks both of you! I’ll give that a go tomorrow.

All the best



OK I tried that - made a group of ‘all leader text’ and can see how to turn it on and off. However there is text it doesn’t select, and even if the group I make is made to be not visible, when zooming out it then goes to infinity again…

@VahePaulman Can you tell me steps to fix my file?

If you’re facing the same problem discussed in this topic, upload you SketchUp file here, so the community members can fix it (if possible) and give back.

@VahePaulman Here you go that’s the file, My model was here then it disappeared, I don’t know where’s it, I hope it gets fixed. File was too big so I Uploaded it on Mediafire


Your scene is completely empty @saedelgabry1.

There’s no geometry to recover. On the other hand there are some models under your Components tab. I’ve put some of them in the scene, so you can see.

Also, your camera position was very far away from the axis. Look at the VCM Box - some 12.500.000 meters long. You could easily fit the entire planet Earth in this distance.

Oh god, everything is lost, anyways thanks for helping

Your model was broken in the strangest way I have ever seen! There were quite a few Group and Components defined, and most of them claimed they had instances but there was no content whatsoever in the model’s entities collection. I regenerated each of the claimed instances using its transformation and the attached is an image of what I got. Does this bear any resemblance to what you thought you had?

1 Like

This doesn’t seem to resemble a modern villa? Is this a new trend? :smiley: Did you notice that the Layers wouldn’t allow to be deleted, claiming they were not empty, while all of the present components belonged to the default layer?

Yeah, that model somehow got its geometry database scrambled in ways I’ve never seen before! There are a bunch of inconsistencies about what is there or not.

It’s a new trend in villas to have a gigantic brake assembly! :wink:

1 Like