My drawing disappeared after zooming out. rebuilt it and while I was moving around disappeared again. Help

Shop 2.skp (1.4 MB)

I’ve been using Sketchup for quite a while - not a power user per se but I use it a lot to design things like decks and sheds and what not. I’ve only come across this problem today. The guys said let’s build a shop out front and they know I dabble in this so we made a basic floor plan and I started on a design with layers on everything. Just downloaded a model of an overhead door and was fitting it in and doing trim and when I went to pan underneath to delete a line everything disappeared. I went on line for a bit and found this seems to be a problem. I don’t know what I did but after selecting all and trying to copy and paste and what not it came back so I save a copy as Shop 2. I worked on Shop 2 for a while and then everything there disappeared as well. I’m looking at Model Info / Stats and I have components there. My layers are all turned on. Maybe when I downloaded the OH Door there was an artifact downloaded in the distance that’s causing this? Please help.

Have you tried from the menu Camera >Standard Views >Front
You may have zoomed way out and your model may be a tiny dot somewhere.

The camera in this model was messed up. Try this:

Shop 2_gm.skp (1.4 MB)

No sir, that doesn’t change anything.

Excellent - that did it sir. Much appreciated. What do you mean by the camera was messed up?

I notice that if I try and orbit around to look beneath the building the model will disappear. Why would that be? Never had something like that happen before.

These are the (hidden) settings for your camera:
Camera eye ( -2147483648’ , --2147483648’ , 2101827785’ )
Camera target ( -2147483648’ , --2147483648’ , 1898893328’ )
Camera up (-0.13827, 0.172683, 0.975224)
Something has got corrupted somehow, maybe by excessive zooming in parallel projection mode. I fixed it with a Ruby script to set it to something sensible. Sometimes you can fix it using the zoom tool and dragging a small rectangle over the origin.

Huh. I’ve never used anything other than Perspective. Interesting, Thank you very much.

Hold on, there’s something else wrong. There’s some geometry a large distance from the origin 382832771.45m away in fact.

1 Like

Yes everything just disappeared again. “382832771.45m away in fact” LOL. Long distance indeed.

How did you even determine that??

I see it’s a part of the over head door model I downloaded.

I used Ruby Scripts to examine the model for enormous groups.

In this component: Overhead Glass Garage Door there’s a group with some geometry a long distance from the origin up in the positive z-axis(blue) direction

I’ve tried to delete the parts that are way up high without being able to see them, so I’m not sure what I’ve deleted. Check your garage door carefully for missing parts.

Shop 2_gm_2.skp (1.4 MB)

The biggest group is your Truss Set now at just over 17m, so it should be ok now.

I did the same as what you did. Will try this. Yes - it seems to have worked. Thanks for your help.

1 Like

I was adding and deleting components from 3D warehouse, everything in my model disappeared please help! I did everything with hide commands and stuff but it doesn’t show ! but I can see that my components list is there but I cant see my whole model ! HELP!!

Share the .skp file so we can help you.

Likely you have some entity at a great distance from the origin.

It wouldn’t hurt to purge the unused stuff. That’ll reduce the file size by more than 55%.
Screenshot - 5_3_2020 , 7_48_56 PM

I’m uploading a file and will share the link when it finishes.

How will you use this model?

I don’t know how it got into the state the it is, but it’s like the camera is confused. From the Camera Standard Views menu, choose Iso, then Top, then Iso.

Also do a Zoom Extents.

but would the model show back? so its not deleted after all !
what do you mean by how will I use the model?