Model disappeared after hitting zoom extents

Howdy everyone - I was working on a framing layout for an upcoming deck project, hit zoom extents and the screen went white. Now I’ve basically lost all functionality, can’t draw, create rectangles, etc etc.

I use SU a lot and have never had this issue.

Appreciate any help, thanksFraming Plan.skp (155.1 KB)

you may have something on mars…

can you post the file?


Looks like you might have got something miles away away from the origin !

Try this…

Assuming you have a view showing what you expect…

Edit > Select All
Now use Select by fence [left-right-crossing?] to pick what you can see.
Entity Info might now show somethings left over - outside of the view !
Press <delete> to erase those.
Now re-zoom… any improvement ?

1 Like

sure how do I do that

Framing Plan.skp (155.1 KB)

Read my steps…

The drawing is a bit away from the origin at 73 feet but that’s not the main problem, its the camera setting.

Your camera is set weird. If you’re interested I found this by opening a Ruby console and doing this:

> cam =
> puts cam.eye
( 6' 8 19/64",  3' 9 53/64", -2147483648' )
> puts
( 6' 8 19/64",  3' 9 53/64", --2147483648' )

To fix it, do this:

eye = [100.feet,30.feet,200.feet]
target = [100.feet,30.feet,0]
up = [0,1,0]

or download this file

Framing Plan fix.skp (158.6 KB)

I don’t know if this is your entire drawing, but just because you can see it doesn’t mean its fixed. You’d be best copying what you can see and pasting it in a new file. There’s something messed up, possibly coordinates of some lines too. When you do select All and zoom extents, the camera still gets messed up.

thanks for your help - I downloaded the file and tried to insert into SU but got this message. So I uninstalled SU, downloaded the newest version and still get the same message.

Sorry, I forgot I was using the new Sketchup 2018 that only came out today. This is saved as a 2017 version:

Framing Plan 2017.skp (158.6 KB)

1 Like

Life saver, worked perfect. Thank you, if there’s somehow I can repay you let me know. Saved me about 4 hrs of drafting time.

Thanks again!

I’m coming late to this party!

The problem with your original file was two Text objects that had somehow gone astray beyond the moon. To restore sanity you have to erase these bad Text objects. The camera adjustment that @McGordon provided is just a temporary fix, as the camera will again go mad the next time you invoke zoom-extents unless you first get rid of the offending Texts. The fix @TIG provided is one way to eliminate them, then you can do the camera adjustment.

This bug has been reported several times before, typically when someone is annotating a model that is basically 2D - such as yours. Unfortunately, since the issue is usually not detected until long after the damage was done, nobody has yet been able to create a repeatable test case that Trimble could use to analyze exactly how the code is in error.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.