Model disappears when I hit zoom extents


#1

It has happened on several of my models. They disappear when I hit the zoom extent tool button. I try hitting it again and zooming way in but the model is gone, all except for part of one label. I saw something about the Intel Graphics Card and the 2017 64 bit version. If that’s it I’ll go back to 2016.


Zoom causes drawing to disappear!
Camera Position
#2

Can you share a model in which this happens?

Commonly the problem is that there’s some small entity at a very great distance from the rest of the model. Hitting Zoom Extents makes SketchUp try to show everything and the field of coverage is so large you can’t see anything.


#3

Thanks for the reply Dave. How do I share the model? I tried uploading it but its a non-supported file type (which is weird).


#4

If your model is <=3MB you can upload it to the forum using the seventh icon from left above the typing area in the reply window. If it is bigger, you will need to upload it to some file sharing site and provide a link here.


#5

The file you should be uploading would have the extension. skp


#6

Here you go…

Garage Floor Plan Updated Interior Walls.skp (626 KB)


#7

Got it!


#8

You do have something balled up pretty good. I see only five components other than Lisanne and they all appear to be blank as if you erased their contents. The statistics indicate there are 855 edges but no faces in the component called Bedroom and Roof. Similar issues with the others, too.

I’d say this SKP file has gotten corrupted somehow. The style thumbnail doesn’t even show the box and cylinder like it should and even selecting a new style doesn’t bring them back.


#9

All the models I had this issue with were originally created in Make 2016. After I downloaded 2017 this started happening and always by hitting the zoom extents toolbar button. Everything just zooms to a single point. I may just go back to 2016 and use that since it never had this problem. Thanks for looking into it.


#10

It would be interesting to see one of your 2016 SKP files. I wonder if it would cause me the same trouble in SU2017.

It does seem that you’ve managed to invert the axes on this model I’ve been looking at.


#11

For some reason, the camera in your view has moved away to the far end of the universe, making everything except that battery room text too small to see (it is screen text, which anchors and sizes to the view not the model). I can restore the camera to sanity, after which the model contents are again visible, but doing zoom extents causes the camera to blow up again. This suggests there is something very far from the origin, but I haven’t been able to find it yet. Stay tuned…


#12

I can’t find it either.


#13

So I fixed it by correcting the camera, selecting everything, copying, and pasting into a new file. That has made it healthy, but I don’t understand why.

Garage Floor Plan Updated Interior Walls 2.skp (112.9 KB)


#14

Here is a 2016 created model that I never saved in 2017. Hope that helps…

Exterior Finishes v2 with dimensions - metric.skp (1.18 MB)


#15

I just sent you via email a 2016 created model that I never saved in 2017. Hope that helps.


#16

Yes, I just downloaded it and opened it in SU2017. It looks reasonable to me. Like Steve, I don’t know what happened in your other files to cause that weird issue.

I’d be making components of parts of the model but it works.It would be wise to use proper face orientation, too. And Zoom Extent doesn’t do anything bad.


#17

Yes! I followed your steps and got it back too! Thanks. Now at least I have a recovery process. Still a mystery. Thanks for digging in and working on it.


#18

Thanks to both of you for all your help! Zoom extents doesn’t always doing something bad, but eventually it has gotten me into this problem everytime. I use that button a lot when I want to see my current rotated view in full screen.


#19

Hi

I’ve had the same problems. Actually the first thing I did had been to copy the drawing and paste into a new file, with new file name. Then could work on it for a day with no problems. Then all of a sudden the same thing happens again and the file becomes corrupted. So copying across to new file doesn’t seem to address the cause of the issue.

Anyone know what really causes this and how it can be addressed? I can’t work with Sketchup if I’m scared that at the slightest touch of the mouse all my work is gone!

Thanks

Eric


#20

In all but one case (the one in this topic) where I’ve seen this, the immediate cause has been an entity that is incredibly far from the rest of the model or that has somehow convinced SketchUp that it has an enormous bounding box. By “incredibly far” and “enormous” I mean with values that are so large they are obvious nonsense. Distances on the order of the distance to the Sun or larger! Trying to view an entire model when one of these remote entities is present causes everything to be so small that you can’t see any of it.

Finding and deleting the defective entity heals the file (I have my own suite of Ruby code to hunt for them). Copy/pasting the model to a new file also usually fixes the problem because this forces SketchUp to rebuild the geometry database in the new file and the obviously errant values get discarded or repaired during the rebuild.

Presence of gigantic values strongly suggests an error in which something is divided by a value close to zero. My suspicion is that it is a downstream consequence of a bug that somehow gives an entity a nearly-singular transformation and an explosion occurs when SketchUp later needs to invert that transformation. But so far nobody has been able to find a reproducible sequence of actions that provokes the problem. It tends to show up suddenly after such a long sequence of actions that the user can’t reconstruct them. Fortunately, the problem is pretty rare (no comfort if it happens to you, but that’s why it is hard to debug).