Sketchup Make 2017 Zoom Extents causes model to disappear


#1

There have been lots of reports like this, but those threads are closed. I’m uploading a very simple but busy model of a 2D floor-plan that causes the problem, FYI. When this happens, the saved model is also bad, and when I try to Open the original model, it’s bad also. However, if I close Sketchup, and double-click the original model, Sketchup reopens and opens the original model successfully (thank God). Of course, if I click Zoom Extents, it’s a rinse-lather-repeat.

Update: I guess I won’t be uploading the model, can’t find any upload dialog.


#2

Have a look at this screenshot and then attach the model in your reply to this post.

Upload%20Button


#3

The symptoms certainly sound like the wayward text bug, which can usually be repaired. But we’ll need to see your model to be certain.


#4

Like the others said, it’s hard to say what this issues is without looking at the model. One thing you can try, after re-opening and NOT zooming extents…is to copy just the model area, don’t select all, just manually select your model only. Then make it a component. Then right-click and ‘save as…’ to save it to your drive. Then open that file and zoom extents to see what happens. Good luck.


#5

Oh, THAT button.Shower floor - 2nd ed.skp (215.3 KB)

As you’ll see from the model, I am a rank beginner at this, have yet to use components, etc., but I’ll give eric-s’s suggestion that a try when I get some spare time. Maybe after I become more proficient at navigating.


#6

Probably was some bit of text a million miles from the rest of the model. Easily fixed by selected all of the stuff close to the origin to copy and paste in place in a new model.
Shower floor - 2nd ed.skp (93.9 KB)

Looks like you might need a “3rd ed”. The 2nd ed is very difficult to read as it is.


#7

Yes, there was a text “#1” that had blown up. This is a known bug that occurs when you edit the face to which a leader text is attached. The best way to avoid it is to delay attaching leader text until the part of the model it will reference is finished and won’t be edited further. The Trimble team is aware of this bug, so we hope they are working on a fix for SketchUp 2019.

As @DaveR observed, your model is quite cluttered and hard to read. As you noted, you need to learn about components and groups to keep unwanted parts of your model from interfering with each other. Also, for texts and dimensions there is an exception to the advice to draw everything on Layer0. Because they are not geometry (edges, faces, things made from them), texts and dimensions can safely be associated with other than Layer0. Using layers and scenes would greatly enhance the clarity of your model.


#8

“Quite cluttered” is an understatement, but every measurement is being used as I cut and shape the real world, using Sketchup mainly to develop measurement data, for which it’s been invaluable. I tried, briefly, to expand my 2D model of the entire bathroom (much less cluttered) to a 3D model, but that can only be described as a disaster. Maybe someday. I’ve got a large home whose floors don’t follow conventional alignment protocols, so I’ve been 2D modelling individual rooms, cutting and pasting (literally) them together to form complete floors, then trying to find common points to align the floors (in one case, by simply drilling a small hole in the ceiling with a long drill, and seeing where it came out in the floor above). Then by laying floor 2 on top of floor 1, I can get a better picture of the big picture. I had hoped to get the whole thing done in one Sketchup model, but that’s a long way off.

And you were right – copying & pasting into a new model avoids the problem, but since there’s already a 3rd ed. and it’s working, there’s no need for a debugged 2nd ed.

Thanks to all.


#9

I tried putting all dimensions into a group and put that group into a “Dimensions” layer in the 3rd ed. That removed a lot of the clutter if the “Dimensions” layer were hidden, but Zoom Extents" still failed as before (the Dimensions layer was hidden). This time, when I restarted Sketchup and reloaded the model, the text “#2” had disappeared. I’m guessing that if I kept doing this, individual texts would disappear, one at a time, until some critical condition was satisfied. As far as I know, none of the faces the leaders pointed to had been modified, although I had added one Dimension that terminated on #2.

These #1, #2, etc., labels were all formed conventionally as leader texts, although I didn’t know they were called that at the time.


#10

FEI: I tried deleting all the leader texts (but retained all the dimensions) and the problem still exists. But this is clearly a dead horse.


#11

Which problem? The disappearing on zoom, or the clutter? We are still here to help if you share the model :grinning:


#12

It’s only dead if you don’t follow up.


#13

It’s the disappearing-on-zoom problem. Clutter is a design-by-newbie issue which is useful to me, but very poor form. But here’s the dimensions-only model that fails to zoom:
Shower floor - dimensions only.skp (188.0 KB)
It may have something to do with the sheer number of labels.


#14

The easy fix is to select the geometry, dimensions, and labels and copy them to a new SketchUp file.

Most likely the problem is a label that is at a great distance from the origin. You can hunt for it or take the easy road.


Shower floor - dimensions only.skp (70.0 KB)


#15

Yes, there were 9 leader texts that had gone singular. I take it you are still modifying this model? If so, you should get rid of all the leader texts because the bug is triggered by certain kinds of edits on the face a leader text is attached to. Here’s a revision with all the leader texts deleted, including the singular ones.

Shower floor - dimensions only.skp (211.8 KB)


#16

Do you really need that many dimensions to be displayed?

You can arrange the visibility by associating them with (multiple) Layers.

Note that when you have a sloped floor, the dimensions are (slightly) different then when viewed from above.

Shower floor - dimensions only.skp (215.9 KB)


#17

Yeah, the original model was built to make it easy to find the dimensions for the parts & pieces to build the shower floor. Dimensions were added as I built the thing and needed to verify the as-built matched the model. I sloped the floor by routing the original joists; there’s an easier way to accomplish the sloping, but I opted for the hard way for this bathroom. The next one I’ll do the easy way. After sloping, the dimensions are, of course, different, but as an old friend used to say, “you’re not building a piano”. Anything to the nearest 1/32" was good. Today I finished building, and everything checks out to within .005" – good enough for government work. Your very impressive 3D model is accurate but for the fact that there is no curb at the entry to the shower, and the pony walls to each side are only 40" high. I was never able to push/pull the floor and account for the fact that the edges of the doorway had to be “slippery” and slope downward; it worked fine in reality.