Zoom extent issue

Hi,
I had an issue with my model disappearing in zoom extents (I could still see it, but barely). I read up on it and believe I solved it, but wanted to see how to prevent this from happening in the future. I followed several of the procedures noted in earlier posts, such as selecting and deleting text, selecting all and searching for far flung components, purging of course, and finally copying the immediate model and pasting it in a new file. This last method did the trick but it took a few tries for it to work, which puzzled me. I saw the snippets some had posted to fix this supposedly known bug, but am not versed enough to utilize ruby console. I did attempt it one though, to correct camera position, again this is beyond my knowledge base, so not sure if it did anything.

I loaded a few components (kitchen fixtures), deleted some, but I didn’t notice anything with text. And as I learned earlier, I now always open up a component separately and then clean it up before loading into my model.

So, my question is, what are reasonable safeguards to prevent this from happening, as it was very frustrating to deal with, and took a while to solve it.

Disappearing a model on zoom extents always ultimately leads back to the same root cause: there is something too far from the origin in the model. However, depending on the culprit, how it got there, and how it has messed up the state of the model, it can be technical and tedious to salvage the model. I don’t know of any method that is 100% sure to salvage every model (I’ve saved a lot of them for people on this forum). So, your question is apt: what to do to prevent it in the first place.

One precaution is always to check out any foreign content before importing it into your model.

For the 3D Warehouse, this means downloading it into a stand-alone model where it can’t damage your real work, and examining it to see what is there. This process is useful both to check out the location and size of the 3DW model contents and also to see whether it has an appropriate level of detail for what you want to do. There are a lot of models in the 3DW that might be ok for stand-alone use but are way over-detailed for embedding into another model. Importing a geolocated model can make a mess if your own model was geolocated somewhere else.

For models from other sources, it still pays to import into a separate model first. But you should also pay close attention to the options settings on the importer. For example, dwg and dxf files are notorious for placing geometry at outrageous distances from the origin. You need to turn off “preserve model origin” to import them safely. Some formats such as stl do not contain physical units, so you have to make sure to make the right choice during import. If you import into a separate model, you can always rescale and relocate the contents there, then copy them into your real model.

There is also a known bug in SketchUp prior to 2019 regarding leader text (the kind that floats on the screen with a little arrow pointing to something in the model). The bug can cause the text to fly off to infinity when you edit the model. The safe workflow is to avoid annotating the model with leader text until you are finished editing the geometry. The bug was mostly fixed in 2019 - the texts no longer fly to infinity - but they can shift to point at strange places that don’t make sense, so the advice still applies but with a different kind of risk.

2 Likes

Thanks for that, and I actually read some of your posts on this topic when I searched it up. I also have been opening components in stand alone models to check their entity info prior to loading into my model. I suspect I may have dragged in a component I downloaded a couple of weeks ago before I was aware about doing that check. I have never (consciously) entered text into the models, but have noticed some text or dimensions in other components and have deleted them before loading into my model. Is ruby console something a beginner can navigate? I guess I am slightly beyond a beginner now as I have spent quite a bit of time on SU the last few weeks and my workflow has improved greatly (thanks to the many here who have assisted me), though I have a lot to learn still.

P.S. I am using SU Make 2017, though hope to upgrade eventually.

The Ruby Console is in itself simple to use. The hard parts are learning the Ruby programming language and SketchUp ‘s Ruby API library.

18IN CABINET BEAD BOARD.skp (391.0 KB) I am having the same issue with a lot of my files but i do not have text in the files can you look over this and see want I did?
Thanks Sean

There is some text in the model according to Entity Info. After inverting the selection, Entity Info shows that it is there. After deleting it, Zoom Extents zoom in on the cabinet as you would expect.

Screenshot%20-%206_12_2019%20%2C%208_43_50%20AM

I purged unused stuff from the file as well.
18IN CABINET BEAD BOARD.skp (231.2 KB)

Thanks how did you do that I have a lot of files I need to fix.
Thanks Sean

I used Invert Selection from TIG’s Selection Hide/Show. Selected the cabinet, inverted the selection, and hit Delete. If all your files are like that one, you should also hit Purge Unused in Statistics.

I’m way confused

What’s confusing?

I am new to this and I have no idea where any of those selections are that you’re talking about sorry I am a newb

I gave you the link to TIG’s extension. You’ll need to get it and install it.

Purge Unused is under Statistics in Window>Model Info.

Sounds like you would benefit from going through the SketchUp Fundamentals, too.

Thank you I downloaded it what I do with it now

I assume you mean you downloaded TIG’s extension. Go to Window>Extension Manager and select Install Extension.

When I go there it’s looking for file extensions .rbz and the item I downloaded is a .rb

If it is an rb you can drop it in the plugin folder. If you don’t know how or where to do that you can .zip it then change the .zip file extension to .rbz and install it that way.

I tried both ways I don’t know what I’m doing wrong is there anyway you can fix The file extension And send it to me I tried just adding the letter and it says it doesn’t work .
Thanks

You should have downloaded an RBZ file from Sketchucation. At least when I follow the link, that’s what I got. I’ve attached it here.
SelectionHideShow_v1.1.rbz (1.2 KB)

thanks you sooooo much