Make Unique texture just goes blank

@robertjuch’s tip for using Make Unique texture isn’t working for me. What am I doing wrong?

I create a rectangle for a portion of a surface with a projected photo that I want to repeat, right click and select Make Unique, and the texture for that portion just goes to white.

Maybe You missed a step with photo projection?

Yes, exactly. That’s what I expected it to do.

I noticed you’re on 2017, and I’m on 2018, so on a hunch, I saved the file back to 2017 and tried it there. Guess what? It’s a SU2018 problem. It works as expected in 2017.

So now what? Communicate this to the SU Team how?

1 Like

I have never reported bugs/errors :wink: But think somewhere on the forum should be an option to report errors.

ps. Usually, I do not use the latest versions of programs, because sometimes there are errors.

is it by chance applied to the other side? Nothing added in the ‘ín Model’ collection?

windows 2018 working, there were some issues related to the native color panel in MacOS Hfgh Sierra. Which could be solved by openening the terminal and enter:

defaults delete com.sketchup.SketchUp.2018 “NSWindow Frame NSColorPanel”

then [Return]

No, clearly the front face, and a new In Model color that’s just a white patch with a name derived from the original Match Photo file name.


I’m on El Capitan still, but I might need that when I do get to High Sierra.

Can you provide the skp file with the image before the “make unique texture” was used?

Can I do so privately? I don’t want to post private client’s stuff in totally public places.

BTW, as a test, I pulled up another Photo Match model I did and tried it there, and the technique works on that one as you would expect.

I noticed that the backface was transparant, was that already the case? Is the texture a png or jpeg?

True enough. I sometimes do that with interiors; create a room as a “backface out” object and then make the backface transparent. (Actually, I first started doing that with UpFront in the '90’s, then about '04, a SketchUp team member showed me how in SU at MacWorld or something.) Tried changing the backface to default and the result is the same. The file is jpg, but it is original resolution of 6k x 4k pix. Yes, unnecessary resolution for the screen, but that never seemed problematic before.

Now I’ve tried regenerating the photo at a lower resolution (1080pix high), and Make Unique texture works, though at a lower resolution.

SUPro 2018 Lower Resolution:

SUPro 2017 at Higher Resolution:

I’ve also noticed that the resulting tiled pattern slightly overshoots the original rectangle that was used to grab a selection. That makes it hard to get exactly the right part, if you ask me.

I tried a test where I took your image and positioned it as a texture, then did a Make Unique Texture, in v2018. I didn’t get the white face, but I did get a scrambled image. I checked preferences, Open GL, and selected Use maximum texture size. After that the texture was made ok.

I repeated the test with v2017, and got the same results. Is it possible you have that turned on for 2017 but turned off for 2018?

Thanks for sharing the skp file. It looks like the bug / error is associated with the size of the image you are using. The 6000x4000 image is choking the Make Unique Texture feature. If you reduce it down to even just 5000x… It seems to work fine.

CD

2 Likes

One thing that could be done to keep the resolution is to crop the original image to just include the area you’re going to repeating.

Funny, when I double checked it was the other way around.

There’s a chance double negatives are going on! I mean to say that with that box NOT checked, I get the corrupt image. With it checked the image comes out ok.

6000x4000 is the native resolution of my Nikon D7100. Earlier bodies (D70 and D80) had lower resolution. Having experimented in the past with throwing full resolution at SU, I’ve taken that for granted it could handle it, so I’m not shocked I finally found a limit.

1 Like

I’m having the opposite experience. After checking that box on 2017, it did the same thing as 2018, and came up white.

Now I notice something else: With that box unchecked, the starting projected photo looks rather low resolution, of course, but when you select the rectangle patch and Make Unique, it’s like SU goes back to the original image and pulls out the higher resolution for that smaller area.

Before Make Unique:

…and then after Make Unique:

1 Like

I suppose Make Unique makes texture with smaller resolution (cropped + decreased resolution) and in preferences you have not checked this. texture resolution

In my opinion 6000px for texture is too much. For example 5 textures with size 5mb makes your file 25mb bigger (for me this is too much). My last urban model with 108 houses was 7mb.

2 Likes

Agreed, for a repeating patch of texture. 6000px is the whole photo. From what I see just playing around here:

  • You can use a high resolution photo for photo match, but maybe I started hitting a limit on what chokes SU.
  • When you project that photo to a large surface, that photo will look low res if “Use maximum texture size” is unchecked, and higher res if it is checked. You can toggle this on and off to your heart’s content; the low res projection doesn’t seem to be permanent.
  • Even with max. texture uncheck, when I take a small patch and make unique texture, it seems to go back to the original image and “get more pixels”, so to speak.
  • As it is, that small rectangle example with the unique texture, when opened in Photoshop for editing is only 740x1064 pixel, which is more like it for a repeating pattern.

6000px wide may be overkill for my old 1680 x 1050 monitor, but for newer 4k and 5k monitors, “screen resolution” is starting to get up there.