Problem when importing High Resolution images

Good day all,

I’m struggling when importing images (PNG) within my project. Here is my workflow :

  1. I have boat plans scanned at high resolution in a PDF
  2. It is converted into PNG at 300dpi
  3. Within LightRoom, I crop different parts of the image to extract Front, Top and Side view. All exported in PNG at 300dpi
  4. The goal is then to import those images along the 3 axis to serve as a base to reproduce the structure of the boat and model the hull as a surface
  5. The image is imported as an image that I scale after exploding the copied image.

Now, the problem I’m facing with : for whatever reasons, the exact same procedure doesn’t end with the same result. With one of those images, it works perfectly fine, I get properly scaled image at high resolution allowing to draw precise splines. On the second image, the resulting resolution is bad and the scaling method doesn’t work at all. For each image, I start from a new project and do my sclaing process before I copy/paste de resulting image into the project (this is because scaling an image scale the whole project meaning all other objects already in the project.

If someone can give me a hint where I need to search, that would be great. I already tried different resolution to see if size of the file or dimension of the image may be the origin of the problem…

I’m joining some screen shots so you can better figure out what I’m doing.
I can only put one image in this post. Will see if I can add the other after.

Have a good day,

The 1st image I try to import…

Now, the result I get in sketchup after importing and scaling… Looks good with high precision…

This is now the second image. Still a PNG, with same format and resolution. Created from the same procedure within LightRoom.

And finaly the result within Sketchup. I created a new project to start from same point but the resolution is very poor. Additionaly, the scaling doesn’t work…

The only difference I see is that one image is on the Y-Z plane, the other on the X-Z plane…

Thanks a lot Mihai,

I tried to look at previous posts but as I’m quite new on the forum, I’m still struggling with the right terms and tags. With your post I will explore it now. For what I see, that should solve the problem.

The first image I imported is already of “reasonable” size (4979 × 4617) and weight 3 Mo.


1 Like

With Use Maximum Texture Size ticked in the OpenGL settings, the max image resolution is 4096 x 4096. Without it being ticked the max is 1024x1024. So that first image is larger than the max SketchUp will display. There’s an extension available in the Extension Warehouse that will split large images after they are imported into SketchUp. Run that. I think you’ll see an improvement in the image sharpness. Large Image Splitter.

Quick example. Immediately after image import.

After running Large Image Splitter.

1 Like

You can import high res images, but the moment you import one with a pixel dimension larger than 4096 in any direction, it automatically replaces it with a low quality one. Just make sure to use maximum texture size and keep it within the 4096x4096 limit and you should be just fine.

1 Like

Ok, now I’m confused. 2048 vs 4096?

…and do the same limits apply to Match Photo imports?. I did hit a bug with throwing inadvertently too large a photo into that.

It’s 4096 on SketchUp Pro 2018 (macOS), at least. I can’t speak to other versions or platforms.

No, the limitation doesn’t apply to MatchPhoto. There might be a limit to that, too, but nothing that has been published. The MatchPhoto window is somehow different, I don’t know if it uses OpenGL at all. It behaves somewhat similarly to a 2-point perspective view.

I wonder if MatchPhoto is limited to 4096 judging by @ChrisDizon comment in this post.

I think that last time I was stretching the limits, quite a long ago, the image I used was larger. Have to take a look in my old files. The nice thing about MatchPhoto is that the larger supported resolution goes into your exports and prints too.