When I import a high resolution landplan into sketchup resolution gets obliterated, how can I avoid this?


#1

I have a high resolution landplan for a subdivision rendering I am working on. The size of the original image is 23699X11887 pixles.

But when I import the image into sketchup to trace over, the resolution gets greatly reduced and I can barely see any of the details.

Here is an example of what happens:

Is there a way to retain the original resolution?


#2

There’s a bunch of posts about this already if you do a search on the forum or elsewhere. First, check in your preferences under OpenGL to see if ‘Use Maximum Texture Size’ is checked.

Second, SU maxes out image resolution so it doesn’t help that your image has 21,000+ pixels when SU won’t show more than 1024 x 1024 pixels. Not enough I know but that’s a different conversation. So to resolve, crop in on your image as close as you can before import. If you need such a huge area, tile it. Break it up into a few pieces, save as individual images and import each and line up to increase resolution.

See example:
Without ‘Maximum Image Size’ selected

With ‘Maximum Image Size’ selected

Image brought in as tiles:

See resolution difference between before and tiled: (faint grey difference between images)


#3

Thanks so much. That worked perfectly. Yes, unfortunate that one cannot import it as one image, but that was a good work around albeit a little bit more work.

Thanks for the reply man, you really helped me out.


#4
  1. (As already mentioned by Eric) enable use maximum texture size if your graphics card supports it.

  2. If your graphics card does not support it, or the image exceeds the supported size, split the image into image tiles. This is a bit laborious except if you use Large Image Splitter.


#5

Thank you for posting that, @Aerilius. I was going to hunt up your extension when I got back to my computer so I could share the link. You got there faster. :wink:


#6

@Aerilius, I am trying out your extension as it could be extremely useful for importing PDF floor plans if it work the way I assume.

I have tried it and the default setting appear to be 1024 pixels. That does appear to split the PDF into tiles but I am not sure what you do next. The quality does not change by introducing the splits so presumably there is another step after that?

Is the default of 1024 pixels built into the extension or does it derive it from my graphics card somehow?

(On a really minor point, there is no such word as “splitted” - it should be “split”).


#7

It works on raster graphics whose imported image size is bigger than the resolution that SketchUp displays. Once split into tiles, each tile has a size small enough that SketchUp should fully display it.

PDFs are special because they are vector graphics. SketchUp imports and converts them to raster graphics and only that resolution is what my extension can access. There is no control over the resolution at which SketchUp rasterizes it, except maybe in the PDF import dialog?

You could of course rasterize the PDF externally at a large resolution and import the raster image.


#8

on a mac I convert pdf’s with sips

# from ruby
%x[sips -s format png "#{path_to_pdf}" --out "#{path_to_png}"]
# from Terminal.app
sips -s format png "path_to_pdf" --out "path_to_png"

john


#9

John

I am never sure how to get Ruby script into my system and don’t know whether it permanently alters the SU software or only each time it is invoked.

Is this a preliminary to using @Aerilius’s extension?


#10

Do you have control over the image resolution without using -s dpiHeight <number> -s dpiWidth <number>?

Sips is/was Apple’s scriptable image processing system (why did they remove the manual page for it?), just an alternative to other command line image editors (like ImageMagick) or GUI image editors (like Gimp or PhotoShop).

Neither related nor needed for this extension, but one possibility if you want to try to convert a (vector) PDF into another (raster) image format first so that you have control over the maximum raster image resolution.


#11

Most of the PDF drawing files I import are not vector based. Things would probably be a lot easier if they were. They are image files so you can only draw over them. The poor quality resolution then makes that process not only tedious but also pretty inaccurate. Is your extension going to help with that?


#12

@simoncbevans , sips is under the hood on every mac, other apps can use it instead of inventing their own…

you could just use Preview.app and save the pdf as png…

the code would be more useful in something like AE’s extension…

from where?
I just pulled the man from my system sips_man.txt (4.8 KB)

john


#13

Sorry, forgot the original link. But this goes off-topic…


#14

John, as I am a Bear of Very Little Brain, I am still unsure of the workflow. Does turning the pdf into a png improve it or just make it suitable for the extension to work on?


#15

makes it suitable for the extension to work…

john


#16

OK, I have just tried this. I took a drawing in raster pdf format and imported it into Preview. I then saved it as a PNG file without altering default settings. Then I imported it into Sketchup and invoked Large Image Splitter. It works. It does improve the resolution. I tried it at the default pixel count of 1024 but also at 512 and 2048. The higher the pixel count, the longer it takes to process, but the end result looks much the same. I have a 1080p graphics card.


#17

try it with a .tiff export from Preview as well…

although the files are bigger it’s a native format on the mac and is both better quality and more performant…

john


#18

Oh my, you were right! It is a MUCH larger file (more than 100x the PNG version) so it takes a long time for the extension to process. It does produce a pretty crisp end result so it’s worth waiting for.

Whilst it would be great if all this functionality were built into SU from the off, it’s great to have a solution to a problem that I encounter frequently and has been a bugbear for quite some time. Many thanks for all your help.


#19

Unsurprisingly, a Sketchup file that has a high res image in it results in a very large CAD file.

In the trial I made, I exported from SU to LO. Everything looked fine and high quality. I then decided to print to PDF. That created a much smaller file (small enough to upload here) but the image became washed out in the process. I haven’t seen that effect before. Does anyone know what could be causing it?

Untitled.pdf (385.3 KB)


#20

I think I have seen it reported here on the forum - probably a bug affecting some Mac users.