Imported PDF/Jpeg/Tiff blurry


#1

Hi there,
Have searched high and low for a solution to this problem but no joy yet.

I am running Sketchup 8 on Mac OS 10.6.8.

Whenever I import a PDF, JPEG or TIFF as an image (say, in order to trace or mark up an existing 2D ground plan), the image becomes blurry/fuzzy, as if it has been enlarged too much. It doesn’t seem to matter what scale I set it at or what size the image file is.

I have tried fiddling with the OpenGL settings with no change.

The exercise I am attempting is very simple, to annotate an existing set of ground plans with measurements and labels, which I know is a basic thing to use Sketchup for but I’ve no simpler option at the moment.

Any advice or explanations are most welcome. Thanks!


#2

please attach your file so we can see and make a solution for that. thanks.

-kage


#3

here it is CSC-BERKELEY STREET- GRND FLR PLN.pdf (149.0 KB)


#4

When you import a large image, SketchUp will downsample it so that its largest dimension will be 1024 pixels. If you check the “Use maximum texture size” box in Window menu>Preferences>OpenGL (might be a different menu on the Mac), this is usually doubled. The only solution to getting the image in at full resolution is to pre-split it into 1024x1024 (or 2048x2048) chunks in an image editor, importing those one by one and placing them side by side into SketchUp.

Anssi


#5

Thanks for this tip, however, the settings I select in OpenGL pane don’t affect the image. My PDF is 612x792.


#6

The PC version of SketchUp doesn’t support importing PDF files, so I don’t know exactly what is happening here. Possibly your original PDF, if it contains, as you describe, annotated ground plans, is a resolution-independent vector image and the image size you quote is what SketchUp converts it into. Or is it the original paper size in millimeters?

To get a decent print of a black-and white architectural drawing in raster form it should be at least 150-200 dots per inch, that is about 1250 x 1750 pixels for an A4 page.

Anssi