Jpeg import blurry

I am importing a jpeg into SketchUp 2019 and once in SketchUp the image goes blurry? Can someone help?

There’s a maximum limit to to size of images. If the image is larger, SketchUp will downsample it. There’s an extension to split large images that is designed to help. Look in the Extension Warehouse.

Never mind, I got it! Thanks!

Thank you for your response! What should I be looking for in the warehouse? What could I look under?

You can do a search. It’s called Large Image Splitter.

Here’s an example of what the extension does. @TheOnlyAaron is probably interested in seeing this, too.
Before splitting:

After splitting:

Before:

After:

2 Likes

Hello, Dave.
I impot this image SU2017.

Large Image Splitter gives this error.
What can be the problem?
image%20splitter1

I expect this:

It isn’t compatible with SU2017.

Dave,

When I am asked to input the pixels I want higher is better, yes?

Giocondo (Gio) Susini, Architect
M. Arch, RA (VT), OAA, AIA, NCARB, LEED AP BD + C

I’m sorry I didn’t pay attention. :pensive: Thank you.

I generally just use the default 1024. You could try 2048 and see if it’s any different. No point going larger, though.

No worries.

Dave, Thanks for this! I have another question:

I am importing a jpeg of a house plan and want to scale the image so that when I use the SketchUp measuring tool I get the measurements that are on the plan. How do I calibrate the drawing?

Thanks!

When I do that I use the Tape Measure tool to measure a line of know length in the image. Then I type the correct dimension and resize the model. Make sure you click at each end of the line with the Tape Measure tool.

If “Use maximum texture size” is checked, the image becomes clear.


Yes. Sometimes that helps. Sometimes it doesn’t. It depends on how large the image is. If it’s larger than 2048 x 2048, it’ll still be down sampled and will get blurry.

Image large is 7072 x 5053. 4,42 MB

So as I said, it’ll be better with Max Texture Size enabled than without it being enabled.

Dave,

I get a warning when I check the Max Texture Size box about slowing down the computer. I have a 2010 MacBook Pro and my graphics card is a NVIDIA GeForce GT 330M 512 MB Intel HD Graphics 288 MB. any idea if this is goos or bad?

That warning is normal. You’ll have to experiment to see what happens to performance if you have it enabled. On my 2019 MacBook Pro things do get pretty slow.

If you leave Use Max Texture Size disabled, there’s no point in setting the extension to higher than 1024.