SketchUp is making my JPEG really blurry

I am currently trying to create a studio plan using a JPEG image of a large studio. When I import into a plain SketchUp file (I am using SketchUp 2022) the resolution appears blurry. I tried to use the large image splitter extension but that doesn’t seem to do anything. Can anyone help?

How large (in pixels) is the JPEG file? You mist post it here for others to examine and comment.

You can check window-preferences-opengl-use maximum texture size…

My JPEG resolution is 595 x 841 (420KB)

Screenshot 2022-05-28 at 13.30.46
My JPEG needs scalling up so needs to be larger scale 1:1

Turn on Use maximum texture size

That’s not very high res to start with. Not large enough for Large Image Splitter to really have any benefit. Even using Maximum Texture Size won’t matter in this case.

Where did you get the image and can you get a version that actually is hi res?

1 Like

That is a pretty low-resolution image by today’s standards. If you open that JPEG in Preview (just double-click on it in a Finder window), does it look any better than it looks in SketchUp?