Looking for a way to import high resolution images into sketchup

Having an issue when importing a high res image in sketchup. the image gets reduced and looks blurry once imported. Do you guys have any trick to solve this issue?

Thank you!

Thank you! i just found another trick. You can increase it from the settings

I think that a difference with the large area splitter would be that the largest single material will be ok with most GPUs. the use maximum texture size would give a single material that would be more demanding. But I am partly guessing about that!

1 Like

Thanks for your reply! i tried both and i didn’t feel the difference ( for my case). I think a good Gpu is needed for that.