Image import quality

Is it up to my graphics card that the imported image is blurry?

I cannot trace through the raster image in Sketchup, but nice and crisp in Layout. Is it up to graphics card? Anything to be done?
OpenGL preferences are already at maximum.

Screenshots:
https://drive.google.com/drive/folders/1AgxM1j0NjFVa_SSAvaTA3LjS5RWdGq0j?usp=sharing

SketchUp does have resolution limits. Your graphics card could have an impact as well. Can you share the original raster image so we can see what you are starting from?

What version of SketchUp are you using? Your profile indicates SketchUp Free (web) but that’s not what your screen shot shows. And if you were using SketchUp Free you wouldn’t have access to LayOut.

Thanks Dave: uploaded here raster folder

I’ll take a look at your image.

It definitely is larger than the max size SketchUp will display. Might be an option depending on your SketchUp version.

Please correct your profile.

This is what I get when I import your image into SketchUp Pro on my machine with Max Texture Size enabled. Click on the picture to see it at full size.

I ran Large Image Splitter on it and go this:

.Not an option for you if you are using SketchUp Free, however.