Resolution of imported image files


#1

This is a topic that has been exercised before, for example here: Image resolution in Sketchup

Applying OpenGL maximum texture size does help a lot but at the expense of slower operation. I believe some cannot take advantage of that at all because of their graphics card, so it is not a great solution. Also, I have just noticed that when you transfer to Layout, all the resolution acquired gets lost again. So for output purposes it is nigh on useless. Unless I have missed something - always possible with me.

It seems to me that improving this would help enormously when importing, say, DWG files as you can import all the text that SU cannot normally cope with. By importing the vector info in the normal way and using an image file as an underlay, you could have the best of both worlds. But you do have to be able to print out the result as sharply as you see it in SU.

I don’t know how, or even if, all this can be achieved. But it would defo be high on my wish list for SU 2018 or a plugin.


#2

What resolution settings are you using in LayOut? I keep Edit quality at Low but set my Output quality to High.

Anssi


#3

Anssi

I attach screen grabs of what I see in SU and what I see in LO for the same file. This is before I even attempt to output anything.


#4

I imported a rather high-resolution PNG into SketchUp with the maximum texture size enabled. This is screenshot of that:

I then sent it to LayOut. This is how it looks like there with the screen set to High quality in Document Setup>Paper. I don’t see much of a difference

But this is what I see if i set Display Resolution to Low. It looks like what you are seeing::

I generally keep Display Resolution at Low to speed zooming in Layout but set my Output Resolution to High to get crisp PDF exports and printouts.

If you get a blurry image in spite of setting quality to High, It might be a symptom of the same glitches that prevent antialiasing from working right umder MacOS. I use Windows.

Anssi


#5

simon, I just checked some of mine that have ‘maximum texture size’ OFF in SU and

they look the same in SU and LayOut…

can you attach your LayOut file?

john


#6

Here you go then.

Untitled 3.layout (1.2 MB)


#7

I don*t know why, but you had inserted the image as an image, and if I exploded it, it looked much better in LayOut. while its look didn’t change in SketchUp in any way. It is as if LayOut takes the “Maximum texture size” literally, and applies it only to textures, not images. Go figure.

BTW, your SU Scenes only save the layer state. With the camera unsaved, it is impossible to preserve the view intact in LayOut when you edit the model-

Anssi


#8

There are things here I don’t understand. I will explain what I did and maybe you can tell me how I could have done it better.

I often import DWG drawings into SU and it works fine as far as vector info goes. But as we all know, text gets left behind. When it comes to something like a topographic survey, that is a serious loss as all the levels annotation gets stripped out. I have always wanted to find a workaround to this. Importing as an image file achieves this but, with default settings, at much too low a resolution to even read. I solved that by changing the OpenGL maximum texture size.

There is a single curved line in the file I uploaded which was drawn in SU over the image. So what got sent to LO is part image file and part SU vector info.

Because this was pretty much a test run, I did not bother to use any of my usual scenes (which do retain camera position).

When I tried exploding in LO, I get absolutely no difference to resolution. So you must be doing something different, and obviously achieving something close to what I was after. I wonder what that was. It would be very helpful to know how you would approach all this if you were starting from scratch with the DWG file.


#9

you need to explode in SU not LO…

what works with, your file for me, is

In SU:

Right Click >> Use as Material [this adds it to the Model materials in SU]

Right Click >> Explode

Preferences >> OpenGL >> Use Maximum texture size

then in LO

Update the Document Reference…

Select the model and change to Hybrid mode…

john


#10

Ah, I see! OK I will try that. Many thanks.

BTW, if you use maximum texture size, will the resolution jump back if you disable it again after doing all you have suggested?


#11

Well, John, I tried repeating what you did, with a PDF import, then a JPG, then a PNG. I followed your sequence exactly but came up with the same problem as before. Looks OK (not great but legible) in SU but is much poorer in LO. I don’t understand how this could be if we are using the same software, unless I am still doing something wrong.

This must be such a common issue for people, I am surprised it isn’t made a lot easier.