How to prevent downscaling of imported image

Hi there,

I am using Sketchup For Web Paid version.

I am trying to import an image of a floor plan into sketchup so i can trace it. As i understand the maximum size of imported images is 1024x1024 pixels. The floor plan is 9464 x 6824 pixels. The problem is that SU is downscaling the image which makes it too blurry. Is there a solution to this problem besides breaking up the image into chunks which would be cumbersome.

Thanks.

There isn’t a way to do that in SketchUp Go. You could split the image in an image editor and import the separate images. With SketchUp Pro there’s an extension that will split large images.

What about a program that automatically traces outlines in raster images and converts them to vector files that i can then import into sketchup. Does anyone have experience with that?

I’ve used several different ones. They can work although you generally shouldn’t expect to use the resulting geometry for more than a reference in SketchUp.

All the raster to vector converters I have tried, before giving up, were far too inaccurate for serious use, and the cleanup work required was usually bigger than drawing the thing anew from scratch.

1 Like

I agree with you. I just tried a trial version of Scan2CAD, which is a top notch program used by major companies like Intel, Nike, and IBM, and the resulting conversion for my old house plans was messy.

However, what i plan on doing is just putting all the lines and arcs from Scan2CAD on a layer and then using another layer for tracing only the lines that i need. Once done i remove the Scan2CAD lines and im left with my own outline which i can adjust after for precise measurements.

The only reason im doing it this way as opposed to just doing it manually in sketchup is because when i import the house plan in sketchup the outlines are very thick and blurry which is annoying to trace. In contrast, the Scan2CAD lines are just regular lines like the ones used with the line tool in sketchup. So they are easier to trace.

I tested something, and the web version does keep the image at the original size. I even tested a 9999 pixels across image.

What it is showing you seems limited though. I’m not sure why that is, but it may be to take care of less powerful browsers and computers.

As you have a Go subscription you could save the file to Trimble Connect and open it on an iPad. The iPad allows as much detail as the iPad you are using can manage. In my test the image look very sharp.

It’s due to the capabilities of the graphics crd.

I’ve had a change of mind. The floor plans im using are old and contain dimensioning everywhere. When using Scan2CAD it produces a rather sloppy job. So i opted instead to just draw a basic outline of the inside walls by doing a rough trace of the floor plans in image format and then use my established measurements to precisely adjust the dimensions. From there i can add the studs in a 2D top view. After that im not sure what comes next.

My very high end M1 Max GPU still shows fuzzy graphics. I think that the web version is hard coded for low resolution, and there is no Use maximum textures size preference setting like there is on iPad and desktop.