"Image file invalid!" when importing?


#1

I am attempting to import a .jpeg as an image into a project and suddenly receive this error message. I have previously imported into the same project with no problem.

Anyone have any idea what might be causing this problem?


#2

Is the extension .jpg or .jpeg? If the latter, change it to the former and see what you get.


#3

Everything I’ve tried is .jpg


#4

Can you share an “invalid” jpg file. I’ll try importing it.


#5

I think your request helped answer my question… I looked at the file size of what I’m trying to import and it’s around 70 MBs. I tried importing a random small image and it imported just fine… sooo… I guess it’s an image SIZE issue? I’m using a 66 MB images in the same project, so there must be some undisclosed threshold in that vicinity…??


#6

Very likely that’s it. Do your images have to be that large? I don’t think you’ll get any benefit from using such large image files.


#7

The images are aerial imagery being draped over a terrain model, so the higher resolution the better. The 66 MB image isn’t even as crisp as I’d like.

EDIT: Actually, I was wrong - I’m using a 153 MB jpeg as the main draped image! It’s not image size…


#8

There’s a limit to the resolution SketchUp will use to display the images.

You should see this: http://help.sketchup.com/en/article/3000169


#9

Yeah, now that i’m remembering the pains I went through to get this resolution, there was some way I had to trick SU into importing the image… maybe it was as a texture…


#10

Did you find a solution, I am having the same problem, it never happened before.


#11

Have you tried importing it as a png? I had a model that had loads of images in it, and it started to crash and freeze. After doing a bit of research, I found that png’s are far “kinder” to the models.


#12

I had this problem and came here looking for a solution without success.
However, I found that I had a number of models open at the same time and this was the problem. I shut down a few models and I could import images again! Not scientific, but I have 3 models open and can import an image.

Hope this works for others!


#13

I don’t understand this forum there are no valid answers to the simple question how do I import a jpg.This used to be a very simple step in SU 8 now it says can’t import Invalid file ! what should we do?


#14

There are no answers to, “How do I import a jpg?” here because that question was never asked. It’s easy to import a JPG and it’s just the same in SU2015 as it is in SU8; File>Import, select the file type and how you’re going to use it, select the file name…

The original poster discovered that his image files were huge. Reducing the image file sizes appeared to help.

If you are having a problem importing an image, share the image so we can see what you’ve got and so we can try it ourselves.


#15

One thing to check:
Is the JPG you are trying to import using the CMYK colour space? SketchUp doesn’t support that. You could use an image editor like Photoshop to convert it to RGB. There is no loss in quality as the RGB gamut is larger.

Anssi


#16

I have this problem too. One thing I have in common with the original poster is that my image is an orthophoto. I’ll bet that for both of us, our image originated in the GIS program, ArcMap. I find that if I open the image first in Snagit, and save it with a new name, the image becomes less than half the size, same pixel dimension and bit depth and sketchup opens it fine. Odd. It wouldn’t surprise me if this problem is originating in the way that arcmap encodes the image. If I can figure this out, I’ll write back.