Photo Import

I have been having poor luck in importing a particular photo into one of my models. I keep getting the error message “Image File Invalid” regardless of whether I try to import the photo as a jpg, jpeg, tif. tiff, or png file. I have had no problems with importing other photos with these same file endings. Further, I have followed all of the advice provided by other sources such as Sketchucation, etc about selecting the format for importing as Image, Texture or New Matched Photo, all to no avail.

Any recommendations are welcome!

1 Like

Can you share the image you’re trying to import? Maybe there’s something wrong with the file.

1 Like

Dave: It seems that I can’t upload the image either in this forum or by replying directly to your note. I get an error message reading “Discourse::Invalid Access” when trying to upload here.

It would seem that your file isn’t really a viable image. What is its file extension supposed to be? Can you open it with anything?

Maybe you could compress it into a ZIP file and upload that. (1009.6 KB)
Dave: OK, that seems to work. See attached. I’ll try to import this compressed file into my model. So, it appear that the photo is just too large for Sketchup to handle without compressing?

Dave: OK, that didn’t work either. I still get the “Image File Invalid” when trying to import the sipped file into the model.

I wasn’t suggesting that you import the zipped file into SketchUp. SketchUp won’t import .zip files. I was only suggesting you zip it to upload it here.

It’s not really a huge image file. It wouldn’t import into SketchUp for me either. I opened it in an image editor and saved it as a .png file which imports fine.

I think the forum converts it to a .jpeg file, though.

Hmm, interesting. I also saved this image as a PNG file, but got the same error message when trying to import. Which editor die you use to convert file type?

I used PaintDotNet.

Thanks. I’ll try it.

Did you try it with the image I uploaded?

I’ll try that next. Even the Paintdotnet program rejects the photo notwithstanding that you were successful in pulling it into that editor. Something fishy going on here.

Dave: OK - success with importing the image you uploaded. TRhanks much. Now, I need an explanation of what occurred. Very weird.

It is very strange indeed. I have no idea why the same application on your computer won’t open the file while it works on mine. And no idea what is wrong with it in the first place.

It looks like a scanned image. Where did it come from?

The picture you’re using is a Live Photo, or at least HEIC, from an iPhone 8. It will import on Mac with only the extension being changed to something that SketchUp knows, but on Windows that won’t work out.

Here is the file opened in Preview and exported as a JPEG, though it’s likely to be about the same as Dave made.

I can’t import HEIC photos into make 2017 so I screenshot them and import them with no problem - don’t need a third party editor.

As you are on Mac, you can rename the HEIC to JPG, PNG, JPEG, etc, and macOS will import it into 2017 without any complaints.

I tested that with SketchUp 2016 to make sure it does work.

Thanks, I’ll give it a go.

Sorry for the late response, but thanks to all — Dave, Colin, Guido — your advice was invaluable and problem solved!

1 Like

I had no problem importing your file as an image. Didn’t try as texture.

When encountering similar problems with image files, especially JPEGs, I’ve resolved the problem by opening the file in Photoshop and exporting it as a JPEG.