License Woes - Extension Warehouse

**

UPDATE 3:56MDT 11/10/2017:

**
We have a fix in place for this issue. We would love to get some quick feedback from anyone who was having this issue, if you could please see if its resolved. Here’s how:
SU 2017: Open the Extension manager and find the extension(s) with the License Error message. There should be a button that says “Update Extension” visible. Click that and wait for the page to refresh. That should fix the problem.

SU 2016 or earlier: You will likely need to uninstall the extension through the Extension Warehouse, and then reinstall it. That will delete the extension that did not have a valid license, and the reinstall will push a new valid license onto your machine.
---------- end update -------------
Hey everyone, we’re getting a lot of reports from users that the Extension Warehouse is not issuing licenses for Paid extensions the way it should. We’re still trying to get to the bottom of the problem, but it appears that it is affecting all Paid extensions.

If you purchase an extension, you will probably get a warning that no license was found
If you try to install a Paid extension that you already own onto a new machine, or a new version of SketchUp (ie 2017 upgrade) - will also probably get a warning that no valid license was found.

For now, it is recommended to not try to install Paid extensions, as there will likely be License problems.

We are actively trying to understand what is causing this problem so that we can work on fixing it. Consider checking back on the status of this thread every 24 hours - I’ll keep the status posted here.

Chris Fullmer

Hi Chris,

Thank you for the information, it’s a pity that the SU2017 beta testing stages never spotted this.

I’m very excited about SU2017, I own a Pro license and keep my maintenance up to date. I hope this problem gets resolved quickly for the sake of your Pro users.

I’ve stopped the implementation of SU2017 (installation of extensions and setting up my workspace the way I prefer it) due to this problem, but I can report that the problem does not affect all paid extensions nor only paid extensions. Of the few I have installed I can report as follows:

The following have not shown to be a problem with installation (I have not tried using them in the SU 2017 environment yet), all being the latest current version:

  • Skindigo (Indigo Renderer plugin for SketchUp) [paid]
  • Skatter v1.2.1 [paid]
  • Skalp v2 [paid]
  • Profile Builder v2.1 [paid]
  • Layers Panel
  • Click Kitchen [paid]
  • BIMobject
  • Artisan [paid]
  • 3D Tree Maker (3D Arc Studio) [paid]

The following have presented problems, either licensing or otherwise:

  • Window+ [paid]
  • Windoor
  • Truoffset [paid]
  • 2DXY Site Survey [paid]
  • 2DXY Slick Moves [paid]

Let’s see you quickly this gets resolved.

Just to clarify, Profile Builder 2 (and now the latest version of Artisan) make use of the Extension Warehouse license system. If you purchased these products using the Extension Warehouse, your license fill (currently) fail.

However, if you purchased from my stores at:


profilebuilder4sketchup.com

your license should still work.

The problem is specific to paid Extensions that use the Extension Warehouse license system.

Update:

We have a fix in place for this issue. We would love to get some quick feedback from anyone who was having this issue, if you could please see if its resolved. Here’s how:

SU 2017: Open the Extension manager and find the extension(s) with the License Error message. There should be a button that says “Update Extension” visible. Click that and wait for the page to refresh. That should fix the problem.

SU 2016 or earlier: You will likely need to uninstall the extension through the Extension Warehouse, and then reinstall it. That will delete the extension that did not have a valid license, and the reinstall will push a new valid license onto your machine.

Hi Chris,

Thanks for the quick feedback, this seems to work. Except the problem I have with TruOffset has not resolved. It worked fine under SU2016, but there is some kind of load error in SU2017.

I’ll continue loading extenstions / plugins in SU2017 and will report if I come across any other similar trouble.

Hi Chris - this doesn’t work for me. At the main screen it wrongly states my license as a Trial License. This isn’t correct though. I started with a trial and bought it later from the EW.

Hi Max, this typically is caused by purchasing with one email account, but then using a different email account when logging in later. So the Extension Warehouse sees you as a user that has not purchased the extension. I’m not sure if that is what is going on here or not, but I’ll reach to you via email and include someone from our support team that can help sort it out, whatever it is.

Chris

Hi Chris, Thanks for the reply. This morning I already solved this and its exactly as you describe. I posted it in other related thread: 2017: extensions license not found

Would be nice if I could somehow move all the license to 1 email account. Is that possible?

I’m having a similar issue with installing Profile Builder 2 which I purchased through the Extension Warehouse.

After I received the receipt from Trimble I attempted to uninstall the Trial version and install the licensed version.
Going to the, “my extensions” page I found that no uninstall option exists for this extension. The attachment shows this as well as another extension from the same developer, Dale Whaat, which is credited with having been purchased but not installed. I have not purchased Artisan, only PB2 for which I have the receipt.

I’ve twice communicated with Sketchup Support, after verifiying with Mr. Whaat that Sketchup has control over my license and how it’s displayed on the Extension page. Dale did agree that I have not purchased a license for Artisan but was unclear about the state of my PB2 license, although he did agree that I have a valid receipt for that extension from Trimble.

Sketchup support has told me that the license issue is between me and the developer and seems to not be concerned with my receipt for Profile Builder 2 or with the state of the extensions page.

So, Chris, is there a newer fix for problems such as this ?

in the PB2 pane.

First thing this morning I received a license and download for PB2 from the developer, Dale Martens.

Thanks for stepping up, Dale. Once Trimble gets my, “my extensions” in order and removes the misplaced license, currently shown for Artisan, I’ll be able to purchase Artisan for real.

Currently experiencing the issue described in the original post. About 1/3 of my previously installed plugins have a message “Failed to obtain active license for ____. License missing.” in the extension manager. Was working fine until a couple hours ago… Artisan is the only plugin to be totally disabled so far.

I gotta say this extension licensing is a mess

Is it licensed to the purchaser, the PC … the windows user? the email account…? the SU install?

With a small company with 3 lic installs of SU, I have extensions lic to my staff user profile, my company, some thru Extension manager, some direct to the developer its nightmarish and in fact I give up… and avoiding licensed software now…

This is not only a SU problem - I waited three weeks to sort of a new license authorization last year with expensive VR software when my a power surge scrambled my notebook… and then the French company shuts down for 4 weeks summer holidays. the crash meant I had to contact multiple software suppliers via email supprt and ask them to reauthorise my new pc install and wait for them to send me new authorisations…

Here in SE Asia local people use $1 cracked versions of everything… I try to set a good example by purchasing all commercial software but bloody hell its getting complex …

what ever happened to a simple authorisation code text file that I can keep a record in hard and soft copy and retype into a new install…

PS of course even in this case I still had to contact the developer as I was not able to deactivate the software on my old PC [as it no longer functioned]

1 Like

I’m on SU 2016 - didn’t fix the issue. Have completed multiple uninstalls / reinstalls and deletion from hard drive.
Developer has referred me to you as it was bought through EW. Need to get a fix for this asap as my projects are depending upon it.
Is there no licence that can be supplied from developer to Sketchup for use in this issue?
Cheers,
Alastair.

Sorry for dragging up an old problem but I’m having issues with Window+ license. Ive tried both fixes and neither have worked. Any help appreciated.

I have used the extension a number of times on SU17 but not needed the use of it in a while. Again the developers page directs me here.

Regards

I have paid for the extension Estimator_ 2 years ago, but i am unable to log it to Estimators site because
it shows that i am just a trial licenses. This has complicated a opportunity for me.
Can you please contact the extension Estimators owner and straitan this out.

Thank You

One post on your issue is enough, please.

Don’t cross-post the same thing in multiple topics.

Sorry

John Brock, owner of Estimator, had a server problem recently and was able to sort it out, although there was a communication sent out that requested all users enter their licence credentials again and re-register (and contact him if anyone is experiencing problems) it may not have reached you.

Try it, let us know if it worked for you.

I have been in contact with him, he said that he was able to fix his
problem with the people that bought directly from his site but not with us
that bought from the extension warehouse.
Could you please send him a e-mail and ask what is up and if a fix could be
made or not.
Thank you for the response and I will not double up on posts again.

Jeff