2017: extensions license not found

Artisan and ProfileBuilder2 don’t work for me in 2017 because of ‘a valid license cannot be found’. Strange though because these were installed from the extension warehouse

Any suggestions?

I don’t have a solution for your problem but since I plan to sell extensions through the extension warehouse myself I’m also curious about this. I actually have no idea if the license is connected to your SketchUp license, your email address, a specific SketchUp install or anything else.

What will happen next, what you should do

@IAho - your solution doesn’t work for me. I don’t have the option to ‘update license’ in the manager window. What’s also strange is that the warehouse is reporting my PB2 as a trial license…?! I have bought it from the warehouse and have been using it since it was released…???

I am having the same problem with ProfileBuilder2. Very frustrating.

The Extension Manager “Update License” button does not seem to work.

Profile Builder 2.1 doesn’t pose a problem for me on SU2017, but several others do.

Also take a look at Extension Warehouse License Woes

Just found out I had bought the PB2 license using another email account.
Is there any way to move all my existing licenses on several email accounts to 1 Trimble account?

Hi maxB,
Did you ever resolve the issue? I’m having the same problem.

I think I just logged out of the SketchUp extension warehouse and logged in with my 2nd account. There’s no way to merge both accounts but at least all plugins work again.

I have the same problem ! bloody confusing

Pretty Basic question then for any SU support…

If I purchased an extension under one login account …

Can I use that extension logged in under another login?

or do I have to keep flipping extension logins to use different installed plugins?

At the moment I cannot get anywhere with my ARTISAN purchase ,

completely baffled and wasted hours trying to sort this out!

I also have this problem. So far none of the maybe 4 extensions I’ve tried on a total of 3 or 4 computers have worked. The extensions all say their license is missing.

However I’ve manage to sell quite a few licenses myself and one user reported a bug that wouldn’t have occurred unless they could run it so obviously the licensing system works for some people.

I’m suspecting this is an authentication error in SU. As we all know the login is extremely bugged and it often takes many attempts to sign in to EW, 3DWH etc. If I remember correctly the return value of ExtensionLicense#error_message /which some plugins expose in a dialog) contained the error code -1. The documented return values from #state are integers between 0 and 4 so I suspect -1 could mean something outside of the license check itself went wrong, e.g. the authentication.

However I can’t replicate it at the moment since I’m now completely unable to sign in from within SU -_- .

EDIT: I’ve managed to sign in now and the error message the plugins show contains “(-1)” just as I remembered it. Does anyone have any idea what -1 means?

I got this today. I was using my Mac for some of a project and moved to my PC; tried the plugin and failed. I tried to reset the serial number but the dialogue box in Artisan doesn’t let you do anything with it.

Any new advice?

I recently purchased “Artisan Organic Toolset” from the extension warehouse. After installing it, it says that my license is not valid. I have reviewed all of the above suggestions to fix, but nothing works. Am I able to get a License key associated with my email address to manually enter? This is very frustrating, as I have spent nearly $60.00 dollars Canadian to purchase.
Any help is greatly appreciated.
Thank you,