LayOut 21.0.392 MacOS Model Camera Settings doesn't work

Yesterday I’ve updated SU 2021 to SU 2021.0.1.
Sketchup seеms to work fine, but today I put my models to Layout and figure out that
model camera setting doesn’t work at all (Standart View, Orto and Scale).

So LayOut is useless.

Already tried:

  1. Manually render Model in LO
  2. Restart Mac
  3. Reinstall SU and LO
  4. Create new clean model and LO file

Nothing helps.

Where can I download previous version of LO 2021 and SU 2021 before latest update?
Or someone know how to workaround this bug?

System Info:
– MacBook Pro 15 2017
– macOS Big Sur 11.1
– External Display LG Ultrafine 5K

If you want the camera view in your SketchUp scene to show up in LayOut, click the Reset All button, then choose the scene you want.

If you want LayOut to control the camera position, still Reset All, choose the scene you want, then change the camera settings.

Whenever the Reset All button is showing, it means that you have set LayOut to take control of the view, and any camera changes you do in the model won’t make it look any different.

Hi, Colin

Thank you for feedback.

I am advanced user and using SU almost everyday.
This bug came from latest update.

My work scenario is following:

  1. Create model using template (with predefined scenes, they control only style, not cameras)
  2. Create layout file from template and past the model
  3. Create 3-4 views for this model and select different scenes for style and manually setup view to Iso, Top, Left, Front.

But since latest update this stop working.

Also I figure out that if I delete all scenes from SU model, I can change views, scale and render type (vector / raster / hybrid) in LO.

I prepared test models and screencast where you can see side by side views to exactly same models:

TEST 1.skp – Model with some scenes from my template
TEST 2.skp – This is copy of TEST 1, but I’ve deleted all scenes from file

Interesting point is that for TEST 1 in LO, there is also bug when I select Vector render in model settings.

For most of the issues, relinking the right viewport to the other file, and then back to its intended file, fixes things. For some reason it current sees itself as a model, but isn’t selectable with a click. You can select it with a right to left drag, but even then a right-click on the viewport doesn’t give the usual model options.

It is curious that while the link is broken that going to vector or hybrid shows the rectangle in the upper right, but fixing the linkage solves that too.

@trent can you see if this example file relates to a known linkage issue?

In a nice coincidence, I was checking on something unrelated, and noticed that one issue being looked into yesterday is a variation of what you saw. So, there is good reason to hope that the problem will be fixed.

The cause of the issue is that the camera was disabled in the scene in SketchUp. The work arounds are either do do the relink trick I mentioned, or make sure the camera is enabled in the scene. You are going to take over the camera in LayOut anyway, so whether it’s updated in the scene or not, you can still do what it is that you want to do.

Whenever the problem gets fixed, you will then get away with having the camera not be updated in the scene.

Thanks, Colin and dan.sheb here is a link to the related topic and work-a-round.

Trent

thanks, Trent.

This works for me, but as temporary solution.
Is there any information when this bug will be fixed?

For me best solution is to install previous version of SU and LO.
I’ve installed 21.0.338 instead of 21.0.392 and everything is fine now.

After more than a month with this issue, still no solution ? @dan.sheb where did you find the old version of SU, 21.0.338, preferably in French.

As far as I can see, we are not able to change any camera setting, tags, style etc. while any scene (but Last Saved) is active, the viewport won’t update. It makes it impossible to work simply with section plans or style, while you need a scene for each view and each parameter…

I’ve requested previous versions in this thread Viewports messed up after update to 21.0.391
SU team shared links both for Mac and PC.

According software update in SketchUp Pro 21.0.392 is still latest version, so there no other solution except installing previous version.

1 Like