Layout viewport of perspective scene from Sketchup seems to increase/change field of view

I am attaching some screenshots — I’ve tried a lot of changes and resets but I can’t seem to work this out or find a topic that helps. Any ideas?


Bryan

I could be on to something, I’ve found the advanced camera tools to reset — in a topic about the grey viewport which I also was going to remove. I had Vray installed as well, and have deactivated it.
— nope that didn’t do it.

Are you using scenes in SketchUp?

Hi RLGL, I am using the scenes, and being careful to update and save, tried reimporting relinking and updating.

Can you share the LayOut file so we can see exactly what’s going on?

Please update your profile. It says you are still using SU 2018.

I am also on my mac right now so I’ll update that also.

Thanks for any help you can share.

In your LayOut file the viewport tied to scene 4 shows the Camera properties have been changed from the Camera properties in the scene. The background in that area or the SketchUp Model panel is dark gray and there’s a Reset button. This means that changes you make to the Camera properties in the scene in SketchUp will not carry over to the viewport in LayOut. The change you made to the viewport override the ones in the scene.

When you reset the Advanced Camera settings in SketchUp are also updating the scene? It doesn’t look like you have updated the scenes.

I am, and I have probably caused some considerable chaos in those camera settings while trying to fix this. Of couse, as I’m on the Mac, my panels are not the same, but I see the camera dark grey, and the reset button. I hit it, no update.
I opened up the sketchup model and made some pretty big changes to the Field of view and camera position, to make sure I wasn’t missing anything. When I update in Layout there is no change. Here are the new models:

if the camera panel is grey for you still, then maybe we’ve found a clue, it’s no longer grey for me.

I’ve gone through and reset the Advanced Camera settings for all of the scenes in the SketchUp file you uploaded and updated each scene after doing so. Then I purged unused stuff from the file. That reduced the SketchUp file size by more than 50%. Next I relinked the SketchUp file to the LayOut document and reset the Camera properties for the viewport.

Screenshot - 11_23_2021 , 3_42_53 PM

Scene 4 in SketchUp

The viewport in LayOut.

The fixed LO file. You can get the SketchUp file out of it by right clicking on the viewport and selecting Open with SketchUp.
427 Kurt Loft_II purged.layout (15.5 MB)

BTW, it would be a good idea to make sure you are using tags correctly in SketchUp. I fixed that just now.
Screenshot - 11_23_2021 , 3_50_24 PM

I think you have fixed it, indeed!

I have an older version which I will follow your steps with, the one thing I did not do (besides the purge, that could have helped, too) was go through all the scenes and reset the camera.

Dan, thank you for being here. I will update my profile and get my tag game straight.

Remember if you want changes to scenes to stick, you have to update them. Also remember if you override scene properties in the viewport in LayOut, changes to those properties in Sketchup won’t have an effect when you update the reference unless you reset the viewport.

Who is Dan?

:+1:

DAVE, I’m sorry.
I knew those things, and I remember them. However I was dropping the ball on being thorough updating the whole lot of them. That, along with the purge, must have been the key.

Bryan

1 Like