Layout 2021 - Viewport Issue

Thank you @trent

Fingers crossed.


I hope you are getting work done in 2020, but when you have both time and curiosity, how does the export look if you select the left side model on page 1, and Arrange, Send to Back, then export PDF?

Hi @colin

Unfortunately, I saved the file as 2020 Version, to complete the work, so do not have the 2021 version anymore.



Just to clarify, it’s not only the Export problem, but also Layout not displaying the Viewport correctly.


Trent had noticed that too. There was an update to Skalp yesterday that seems to fix most things, but there are still a couple of bits left over to deal with in Layout.

I think that I have same issue.
LayOut 21.0.392 MacOS Model Camera Settings doesn’t work
Now I try to find where to get previous version of SU 2021, as all my models are already V2021.

SketchUp Pro 2021.0.1 LAYOUT is driving me crazy – VIEWPORT constantly shows a <!> triangle and just does not work. Running M1 Mac. This was not the case on the prior SketchUp Pro 2021.0.0.

Do you have Auto turned off?

2021.0 Mac disk image is here:

Hi all I wanted to give an update on this issue. We have determined that this issue does not have anything to do with the Skalp plugin. This issue is caused by a related issue where unselected scene settings are not being passed to LO correctly.

Mike, your file contains two scenes that have the “Active Section Planes” unchecked.
I know you have gone back to 2020 but the work-a-round for this issue is as follows:

  1. Open the LayOut file
  2. Select the SketchUp file in the bottom lt corner.
  3. Rt. click and select “Open with SketchUp”
  4. In SketchUp go to the Scenes dialog
  5. Under “Properties to Save” check on the “Active Section Planes” on the two scenes that have it unchecked.
  6. Save and close the SketchUp file
  7. Going back to LayOut all should be good.


Related topics


1 Like

Hi @trent

Thank you. This is potentially good news.

Just called it a day, but out of curiosity, what were the two scenes that didn’t have this property checked?


It looks like it was the All Off scene, but also three other scenes:


Thank you @colin

I’ll try opening the file in 2021 and changing those scenes.

The only thing I don’t understand is that the Viewport causing problems was a Plan view, but the ones you listed are all Side Elevations.


Trent has looked at the problem more than me by now, but my guess is that if any of the scenes have those options turned off, it can lead to issues in LayOut.

What Colin has said is correct. The bug can occur if any of the SketchUp model’s scenes have any properties unchecked. The current workaround is to ensure that ALL scenes track ALL properties when you’re working in 2021.0.1. We will have this fixed in the next update, whenever that may be.

Sorry for the inconvenience,


Thankyou @adam and @trent and @colin

I’ll make sure all Properties for the Scenes are checked and let you know how I get on.

Half way through a current project, so fingers crossed.


I am assuming that is referring to all scenes in SU that are used in LO…? Not a blanket "all scenes in the SU file referenced into LO?

The safest thing would be to enable everything for every scene. If you do not, then you need to ensure that the last active scene that you were working in while in SketchUp was one of the ones that you would normally be using in LayOut. Hope that makes sense.

Sorry again for this regression,

1 Like

Ouch! So my default first scene is not used in LO… and I have camera off in that scene… so best to toggle it on… as it is to easy to accidentally save to LO from that view… noted thanks

1 Like

Hi there, I just recently updated SketchUp from 2019 to 2021. For the last week I’ve had nothing but issues with layout and they appear to be similar to what has been talked about on this forum. I use plusspec as a plug-in running with SketchUp but I have tried reinstalling SketchUp and Plusspec but the issues still remain. This is exceedingly frustrating as I am losing money every day.

How can I download 2020 SketchUp so at least I can get on with work?