Viewports messed up after update to 21.0.391

No idea, never seen that before, but it could be a graphic card issue.
Try updating you graphic card driver directly from Nvidia.

I think it is an issue with layout update. It was working fine, I installed the update and now it’s all over the place.

Hi,
We are having the same issues here in the only computer we upgraded to 21.0.391, then opened in a different computer and worked as usual. What we ended doing was uninstalling 21.0391 and continue with 21.0.339 while we find some time to troubleshoot.

Checking the drivers will be a good start as mentioned by Box.

How do you revert to 21.0.339 ?

Drivers updated from directly from Nvidia, to no avail

Back-saving the file to 2020 version and everything is fine

We only uninstalled the newer version, since we still had 21.0.339 installed we just kept working as usual.
Sorry, I got confirmation that we had to re-install the first version of Sketchup 21 as well, after uninstalling the new one 21.0391.

Glad to see you managed to keep working.

Also had this issue with the 21.0.391 update. Nothing changed, but when opening .skp files linked as viewports in the layout file the layout viewports get messed up. All points mentioned by OP also happening to me.

I uninstalled SketchUp Pro 2021 and re-installed the first version from the original 2021.0 installer, which fixed the issues.

@remibro @JulienP

Quick question. How did you set up the viewport? Did you set it up exactly as needed in SketchUp and just blocked it out in LayOut? Or did you set it up entirely in LayOut with only linking the SketchUp file concerned?

It wasn’t changed or set up after the update, but initially set up with tags selected and camera position off as a scene in SketchUp, then the scene was chosen and viewport camera position changed manually in layout.

So I understand, when you down saved the file to 2020 and reopened it in 2021.0.391 the file was fine?

Also, was your file set up in the same way as JulienP describes below?

Trent

Hi all thanks for bringing this to our attention. We have identified that when using a Scene in SketchUp that has the Camera Location unchecked, you will experience this behavior. Checking Camera Location on, updating the scene, saving the file, and updating the scene in LayOut will resolve the issue. The only drawback to this is that the previously established view in LayOut will need to be reestablished, but any Camera overrides in LayOut moving forward we be saved. It is always good practice to establish everything scene related in SketchUp to minimize unexpected results when updating your model. With that said though, this is certainly a bug we need to fix.

Sorry for the inconvenience.

Trent

3 Likes

Reopened in LO 2020 was fine.
I also reinstalled 21.0.339 and it’s working fine.

Thanks for the work around.
Looking forward to this being fixed. In the meantime I will stay on 21.0.339

1 Like

I really have a problem with this bug and not looking forward to have to try to re-fit all my scene-views under my layout work.
How do I revert to previous version without the bug? Alas I did not keep the previous installer versions (apparently too mucht trust).
Suggest you remove the latest version from your download page and replace with the previous one, or send me a link to download.
Awiting you reply, reagards, Jan

This will give you the 2021.0 Windows installer:

Windows SketchUp 2021.0 installer

Hi all, until we have a fix, I have come up with a better work-a-round so that you should not need to revert. I have based these findings on a shared user file (thanks @JulienP :slightly_smiling_face:) that had exhibited the issue.

First, open the LayOut file and identify all the attached SketchUp files through Document Setup, References. - Close LayOut Without saving.

Open each of the SketchUp files you have identified and do the following:

  1. From the Scenes dialog, select all the available scenes.
  2. Under “Properties to Save” check on the Camera Location.
  3. Save and close the SketchUp file

Reopen the LayOut file and all should be good.

Please let me know if you have any questions.

Trent

1 Like

Colin, is it possible to get macOS version also?

Yes.

http://bit.ly/sumac21_0_0

Trent we are having this issue , we tried the suggested fix but not much luck, our work flow has been crushed trying to fix the issue. please help with what to do.
export to pdf make the issue worse.