Layout 2021 - Viewport Issue

Hi

I think I have identified a possible issue with Layout 2021 and how the Viewports are re-rendered when the Model is Updated.

I have attached a screenshot from a Layout Document which shows the issue on the Viewport. This Viewport should be showing a Sectional View, the Ground Floor Layout.

I had to make a minor change to the Model, which I did, and saved. The Sectional Views have all been created with Skalp, for information.

When I reopened the Layout file, and updated the Reference, the Viewport showing the Ground Floor is ‘damaged’. In the Sketchup Model Tray, (in Layout), if I change the rendering mode for the Viewport to Raster and then back to Hybrid, it seems to fix the problem, but can sometimes reappear when Exporting to PDF.

I have noticed this behavior on another Project and thought it was a one off, at the time.

(On the plus side, using Clipping Mask does not cause Exporting to PDF issues anymore, but maybe with one problem being resolved, another has been added.)

On the Project yesterday, It also caused the problem with Exporting to PDF, and sometimes, even though the screen displayed it correctly, the export displayed the messed up version of the Viewport. Took me about an hour to sort the problem last night. As can be appreciated, it is rather frustrating when something so simple takes too long.

Would be interested to see if anyone else has experienced this problem.

I am using the latest updated version of Sketchup and Layout 2021.

Mike

1 Like

To add…

Even though I have seemingly ‘fixed’ the issue in Layout, here is the PDF Output.

Sigh Another Layout issue to fight with???

Mike

Layout 2021 Issue - PDF

And another update…

Changing to Raster does not help.

Once again Layout is causing a job to take way longer than it should.

Attached is another Screenshot clearly showing Layout is faulty. Notice the Scene selected is GF, yet the one displayed is clearly broken.

Mike

Here is the Scene is Sketchup…

I am also attaching the Layout File, as this Project has ground to a halt!!! Completely!!! As I can not Export it to PDF. So, once again, Layout issues costing me time and money!

Serious Help is needed, as I can not continue to work on this Job.

Another Update…

Meanwhile, back in Version 2020…

Blatantly a problem with Version 2021.

So, shelf Version 2021 and back to Version 2020. Ok, I can not use Clipping Masks, but I’ve come to accept that problems in Layout NEVER get fixed. So, it’s a choice of which is the lesser of two evils.

Mike

1 Like

Tried everything I can think off in Layout 2021.

Just does not work properly.

Tried everything. Clearly there is a Bug in Layout 2021 @colin

Tried to also release all the Clipping Masks applied, just in case. No joy.

Another Screenshot.

Mike, downloaded your LO file and made a small change in the SU model and when it updated in LO I got the same issue as you (I’m on 2021)

But I can’t say that I have experienced this issue specifically with my own files though…

I don’t have Skalp

Thank you @paul.mcalenan

I think, (about 75% sure), that this has happened since the latest Update to Version 2021, as I have used it for another Project, before the latest update, and did not have these issues.

I’m now back using Version 2020 as 2021 is absolutely useless to me with this error.

I wonder is Skalp is reacting badly with this latest version of 2021 Layout? Just a completely wild stab in the dark. Maybe @Guy could have a look.

Mike

When I first read your initial post @MichaelSiggers, Skalp stood out to me as an unknown player in the equation. But that is hard one to test because your workflow is based on it and un-installing it would mean countless more wasted hours producing an alternative.

This is no drag on Skalp because I haven’t used it much. I know I did ultimately eliminate it from my workflow because of performance issues that I did not understand at the time. I was just starting to work out my workflow so no loss in not using it for me. Hopefully someone with Skalp can confirm/deny a similar issue as you are seeing to narrow done the search.

Adding my 2 cents only because I feel your pain…and hate the memories of it.

Mike,

I’ve been playing around with the file.

I opened the SU file from LO and then saved it to my Windows download folder where I downloaded the LO file to.

In LO I deleted the problem viewport and then did File>Insert to insert the SU model that I saved to the Windows download folder.

I set up the viewport to exactly how the problem viewport was, did some changes in the SU model and so far the issue is not manifesting itself.

I’ve no understanding of what I could have done to stop the issue occurring

Hi @llavebrooks

Yes, I do wonder if Layout is not liking Skalp.

This has only happened since the Latest update to Sketchup/Layout though.

Unfortunately, I do rely on it 100%.

Mike

Sorry I didn’t reply to your first message, it was 4:30am for me at the time. It’s 7:30am now, and I have tried your example file.

I do see the issue and I’m trying an idea to work around the problem. I will also check with @trent when he is awake.

1 Like

Thank you @Colin :slight_smile:

Mike

Skalp has been a problem for others in the past. Can you try a simple example with and without using Skalp and see if there’s a difference?

Yeah, it has confused me. Originally the document seemed fine. The problem only occurred after I had to update the Model with a slight change, then open Layout and Update the Reference. The problem showed itself after the File Reference had finished updating. When I thought I’d fixed it, it showed again when exporting to PDF.

I conclude that it is Sketchup/Layout 2021 as 2020 is fine.

Mike

Hi @DaveR

I can, but if I can not use Skalp then I really am very very stuck as I rely on it for Hatching.

I don’t have any problem in Version 2020, and it seemed ok before the latest 2021 update.

Mike

I have no need for Skalp in my work but I know from being around here for so long that others have reported issues in LO that were shown to be caused by Skalp. I’m just going by what I’ve read. Like Paul I could duplicate the issue with the PDF exports in your file but I’ve never had that problem with my LO files. Hopefully Colin or Trent will have a useful solution for you soon.

Hopefully @DaveR

If not, then its sticking with 2020 and deleting 2021.

Mike

1 Like

I did get to try a work around idea, and it didn’t help. Still trying other things, but surviving in 2020 looks like the best option for now.

There is a Skalp specific SketchUp issue we’re taking care of, but I don’t think that’s the problem. I think this is an export or print issue. The problem shows on Mac as well, though with slightly different artifacts.

While investigating the other issue I did buy Skalp, so if that becomes relevant I will be able to test solutions that involve Skalp.