Layout scenes and scale nightmare

2017
zoom
scenes
layout
viewport

#1

After updating to layout 2017 I am having a nightmare with many of my scenes and elevations!

I have created full size model in sketch up and created all relevant scenes etc.
In previous version of layout, once I have imported the sketchup model onto the page, I could easily select a scene and it would show the correct view in layout. However having updated, layout does not appear to be recognising the scenes or views properly! The whole document has been affected and almost every scene or elevation has been altered or cannot be seen at all!

When I select a new scene, the model disappears completely and seems to be automatically converting to perspective view and zooming really far out and focusing on a blank area of the sketchup model.

I am now having to go through my whole document and manually zoom into each view that I want, turn off perspective and reselect the correct view (front/top/left etc.) which is taking a ridiculous amount of time. The whole idea of scenes is surely that you don’t have to do this for each image in layout.

Any ideas on what is causing this to happen and whether there is a way to realign the views between layout and sketchup without having to go through every scene/elevation individually?

Thank you


Layout - Updating SU model to 2017 throws out views in Layout
#2

Could you share the LO file so we can take a look? Or if you don’t want to share it publicly, you can send it via a private message.


#3

Are your SketchUp scenes set to save the camera position? I don’t quite know which one, but I have encountered a SketchUp template where almost all the “Features to save” checkboxes in the Scenes dialog were unchecked.

Anssi


#4

I am having the same problem. Something is messed up with the scene link between Sketchup & Layout. Layout seems to ignore the unchecked ‘camera’ scene setting in Sketchup and changes to it’s own camera view. This makes Layout 2017 unusable until this is fixed which is disappointing because I’m really looking forward to utilising some of the new features.


#5

@play404, as I asked Louisa, can you share the LayOut file so we can see what you’ve got going on?


#6

I haven’t used LO 2017 myself much but I’ve heard other people having problems with it. I think one of the things that have changed from 2016 is how scenes with some properties, e.g. camera location, not saved to them are interpreted by LO. If your workflow consists of first viewing a scene containing style, fog, shadows etc and then switch to an other scene with camera only this could be why it’s not working for you.

This is just speculations though. As both Dave and Anssi has said sharing the file would make it much easier to figure out what’s happening. If your company policy prevents you from share it publicly, maybe you can send it in a personal message to one of us or try to re-create your issue in a new model.


#7

It appears as though you do now have to check the camera location for every scene in order for layout to recognise the scenes at all. Without the camera location saved it seems to zoom out really far and focus on another area of the sketchup model (this was not the case in the previous version).


#8

If it’s any help, all the scenes I use for transfer to LO have all the checkboxes ticked, which includes the camera location. I have recently upgraded to SU 2017 and for me it works exactly as it always did.

In the templates I use, I have some pre-set scenes that I just use for working purposes (all borrowed from The Sketchup Workflow for Architecture by Michael Brightman), and others that I use for LO. Only the ones for LO have all boxes ticked.


#9

Luisa,

Be aware that the issue you are seeing is similar to the forum discussion Sketchup 2017 scenes not working as expected in Layout and that we are working on the issue.

Cheers
CD


#10

I don’t quite understand what you mean…
If you uncheck the Camera position checkbox in your SketchUp scene, it will not save the camera position. This means that whenever you update your model in LayOut, the scene’s camera will switch to displaying the view you were last in when you saved your SketchUp model.

The only way to get LayOut views that keep their camera position is to link them to SketchUp scenes that have a fixed camera position. Changes you make by clicking inside the view in LayOut will not stay put (IMHO they should, but this is not the way it is meant to function today).

Anssi


#11

Why would you expect SketchUp to save the camera position if you’ve told it not to by unticking the box?


#12

@DaveR

If you look at the forum post I mentioned above, you can see how folks are smartly using scenes to control layer visibility without having to designate a specific camera location. They are finding the correct view of the model while within LO based on the layout of their assets. It is through this use case that people are having issues when bringing models into LO.


#13

I didn’t explain it that well, here is a video of what I mean.


#14

From SU 2017 you need to have the camera saved to each scene referenced by Layout. Sketchup no longer remembers the unsaved camera kept from the previously viewed scene. It seems a lot of people are having similar issues. Maybe it was unwise to change this behavior.


#15

This is a bug related to the graphics refactor. It will affect scenes that don’t save one or more of these settings: camera, shadow, axes. We’ve got a fix in progress!


#16

Layout - Updating SU model to 2017 throws out views in Layout also reports a similar issue!