New LayOut 2021 - Trouble with updating sketchup model

Hello everybody,

I have mooved from Sketchup Pro 2020 to 2021 for 2 weeks now.
But I can’t work with LayOut 2021… I still use the 2020 licence, here is why :

In LayOut 2021, I import my .skp model with 2 scenes (and the position of the camera is not actualized in my scenes, see image below, sorry for french).
image

Let’s consider that I make 2 different views per scenes so total of 4 pages in LayOut… working well so far. But, then I get two problems:

  • When I export as .pdf, all views have the same camera position than my last LayOut page… the scenes are changing with but not the camera position…
  • If, in LayOut 2021, I go to Files/document configuration, and I click update the sketchup model, all my views take the camera position that I had when saving my skp file… But remember as I explained I chose not to save the scenes with the camera position…

Then, the only way out that I found would be to save the camera position in my scenes and have many many scenes… (one for each camera position). But this solution make it unpractical tu use everyday.

I hope you can help to find sommes issues, it would really help me \0/ :pray:

Looking forward for your ideas,
Alex

1 Like

That’s what we do.

That’s what we do.

In LayOut 2020 we can change the 3D views directly in LayOut and make many different views from the same scene.
In LayOut 2021, we can’t.

I think there is a setting that we missed…

Sure, there must be a bug there, then.

@AlexEnProvence do you think your problem is related to this…

Yes tkx it seems to be the same problem !
Unfortunately the only solution they found until the next update is to use LO 2020. Let’s wait for the update then :alarm_clock: :roll_eyes:

Hi All good news.
You need to

  1. open your sketchup model that the layout document refers to…
  2. open the particular scene you have created (menu->window->default tray->tick scenes
  3. In the scenes tray box set it to view the scenes as “list”
  4. double click the scene in question. it should show the scene and leave it highlighted in the scenes list
  5. look down the very bottom of the scenes tray, make sure in properties to save “CAMERA LOCATION” IS CHECKED
  6. update the scene
  7. save the file
  8. Go into layout 2021
  9. go to the menu->File-Document setup->references
  10. select the particular skp file in question(this will allow you to select it no matter what)
  11. select update , wait for it to update, select close
  12. The model file should still be selected on the page, go to the sketchup model tray, reset the camera and viewport, select your scene, select top in views.

You may need to then re position it on the layout page and fix up your notation but then you are good to go for Layout 2021.

Remember every scene in the sketchup model must have at the bottom of the scene tray in properties to save camera location checked…

Enjoy!

1 Like