LayOut 2022 Sketchup model window not updating

I have configured my SketchUp model with scenes I want to use in LayOut. However when I specify the scene I want to display in the window in LayOut the view just remains the same. SketchUp model has been saved, so that’s not the problem. I have tried “update model reference” from the context menu and that doesn’t work. I have tried making a new LayOut file, using the “last saved view” setting for the window, then copying that window and pasting it into the LayOut file I am working on. This works, but other problems exist. For example, every time I try to set the scale to 1/2"=1’ it sets the scale to 1/4" instead. Other scales seem to work, but 1/2" is just now working. This is driving me nuts. Any help?

I expect there’s a simple solution. Share your LO file so we can see exactly what you have set up and get you sorted out.

Thanks for your quick response. I suspect you would need both the LayOut file and the SketchUp file, and both are over 100 MB. I don’t know if you can accept files that big. both can be downloaded here:

I’m working with the Mac version of the software, by the way. Hope you can help.

I’ve got the files. Presumably the viewport on the page the LO file opens to is the one you are trying to set to 1/2" = 1’?

I changed it to that scale without any problem. It’s a little slow in rendering because it’s set to Hybrid.

On thing I note is that you’ve modified the Camera properties to override those properties in the SketchUp scene. In this case I expect you just ticked the Ortho box but in any case, I would suggest doing anything that results in the Reset button in the Camera section as this can create problems when you need to update the scene in SketchUp.

What happens if you first reset the Camera and then change the scale? Give it a few minutes to render or first change the render type to Raster as that will render more quickly.

By the way, I noticed some incorrect tag usage in the .skp file and there’s some stuff that could be purged. There’s some unused stuff in the LO file that could be purged, too.
Screenshot - 4_4_2022 , 7_45_57 PM

Cool project, though.

Hi Dave:

You have fixed problem one, thank you, which is that I couldn’t get the model window in LayOut to display the correct SketchUp scene. What happens now is that I duplicate the page in LayOut, select the model window, select a different scene in the viewport panel, and get some random view of the model. But when I click the reset button in the viewport panel it does display the correct scene. But then when I change the scale to 1/2" nothing happens. The scale indicator in the camera panel stays at 1/2" but the scale has not changed. If I deselect the model window then reselect it, the scale indicator goes back to the scale that it indicated when I first hit the reset button in the viewport panel. Any thoughts?

Your modification of the Camera properties for the first viewport tells LayOut you don’t want to use the Camera properties from the scene. You’ve overridden that property in LayOut. What you describe is part of the reason I indicated modifying the Camera section is not a good practice. Clicking Reset does get you back to the original Camera settings for the new scene. Note that changing visible tags or style similarly overrides the scene tag or style settings, too, so if your next scene has different visible tags or a different style, you’ll need to reset those properties in LayOut to see them the way they are in the model.

Do you have Auto render enabled? What happens if you first set the Render style to Raster? I expect the viewport is in the process of rendering which, in the selected Hybrid rendering, can take a while with a detailed scene like that. My guess is, if you leave it set the Hybrid, you should change the scale and go get a cup of coffee or something to give LayOut a chance to do what it needs to do.

The first thing I did this morning was to set the render style to raster on all the pages. The auto box is checked, which I presume means I do have auto render enabled. My problem with not fooling with the camera panel is that the scale selector is in the camera panel. What I need to do is to both set a specific scale for the view and position the view of the model within the layout window. To do the second thing I double-click in the model view window, hold down the shift key to get the hand, then position the view the way I want. If I try to set the scale with the window just selected (before double-clicking in it) then when I double-click in the window the scale changes and positioning the view is not possible. So I need to double-click the window to “get into the model” and change the scale in that mode. I have never understood how the “preserve scale on resize” works.

I never had any of these problems in version 2021. Sorry for being so difficult.

Yes. You do.

Changing the Scale in the Camera panel doesn’t result in modifying the Camera properties.

This is what is modifying the Camera properties. There’s no need to do that, though. Just drag the edges of the viewport to show the part of the model. That won’t modify the Camera Properties either. Don’t double click on the viewport. In fact go into Preferences>General, untick that box and leave it unticked.

Here I’m copying the viewport, changing the scene and then adjusting the perimeter of the viewport to crop as needed. I just copied on the same page to save time. Note that the scale remains the same and the Camera properties are not modified. No reset button.

I’m not sure why you are having difficulties in LO 2022 that you didn’t have in LO2021. This thing about the modified camera properties has existed since LayOut was released.

Being able to get into a viewport and move the camera around is great if you are doing a quick one-off document and won’t ever need to make changes to it but this document isn’t that. Leave the Camera properties unmodified and you will eliminate the majority, if not all, of your problems.

Here’s a more dramatic example of the impact of modifying the camera position in LayOut. The viewport at the bottom is a copy of the viewport to the top left but I got into it and modified the camera position to look at the exploded model. Then I added labels to it.

Resetting the Camera for that viewport results in this. The leaders for the labels look like they gone crazy.

But when I resize the viewport, you can see the labels are still attached to the objects they were originally attached to.

By the way, are you still using El Cap for your operating system?

Thank you, thank you. To think I have been doing this wrong all these years. So here’s what works: In LayOut, I delete the model viewport. Then using the “insert” command from the file menu I make a new model viewport. I change the scene to what I want. I change the scale to what I want. Then I turn on “preserve scale on resize.” Then I crop and reposition the window.

You have been a great help, thanks.

You’re welcome.

It’s easy to learn less than good work flow habits and without correct instruction just blunder along fighting the software. It ends up creating a lot more work than it should. Seems to be a common thing and you aren’t alone. Reminds me of a guy who went into a store to buy a chainsaw. He bought one the salesman said would cut 40 trees a day. Next day the guy goes back to the store and complained. “You said this chainsaw could cut 40 trees a day. I worked all day and only cut 10. It doesn’t work! The salesman took the saw, pulled the cord, and the saw roared to life. The guy’s eyes got real big and he said, What’s that noise?!” :crazy_face:

Really it’s not the best work flow to insert the model file more than once. You should have been able to take an existing viewport–maybe from the first page, and copy it to the page in question. Make sure there are no Reset buttons in the SketchUp Model panel and then go to work making the required changes.

Preserve Scale on Resize should automatically get checked when you select the scale.

I’m happy to know it’s been helpful.

Thanks again. BTW my 2014 27" iMac is too old to run El Capitan. Still running Big Sur.

1 Like

Your forum profile says El Capitan. That’s considerably older than Big Sur.

Well, Big Sur is as new as I can go unless I upgrade to the new studio package. Thanks again.

1 Like