LayOut not updating SketchUp Model 2023: Need Help Troubleshooting on Mac OSX Ventura 13.2.1

I’m having trouble updating my SketchUp model in LayOut. I’m using SketchUp version 2023 on Mac OSX Ventura 13.2.1, and my original drawing was done in version 2020. I’ve tried every possible solution but I can’t seem to get LayOut to update the model properly. I’ve even tried re-creating every scene again in SketchUp, but LayOut keeps showing the ‘reset viewport’ option. Strangely, when I create a brand new model, everything seems to work okay and there is no ‘reset viewport’ button showing. Has anyone else experienced this issue? Any tips or suggestions would be greatly appreciated. Thank you!

In LayOut look at FIle>Document Setup>References. Does the path to the SketchUp file match the path to the SketchUp file you’ve been editing?

Yes, in LayOut, you can right-click and open the linked SketchUp model, and the path to the SketchUp file matches the path to the SketchUp file you’ve been editing. However, the issue of the reset viewport button persists.

This indicates that the problem may not be related to the file path, but rather a technical issue with the software or system.

Your screenshot shows you’ve modified the scene’s Camera properties. This overrides the settings. Click on the Reset button in the Camera section of the SketchUp Model panel.

In response to the your advice, I am not sure what is happening as the Camera properties of the scenes were not altered in the original projects. This drawing was completed several years ago and was working fine at that time. However, with the new versions of SketchUp and LayOut and, I am facing the issue of “modified scene’s Camera properties.”

Additionally, I am experiencing a new issue where the scale is being reset, which was not the case previously. After the reset, I have to find the correct scale for the model and move the drawing to its original position. As a long-time SketchUp user, this was not an issue before, and it is cumbersome to get the right X/Y position for the model. Thank you for your help.

Did you save the model on sketchup after making the changes, otherwise layout won’t update the viewports, make sure you save first on sketchup before going back to layout.

Yes, I followed the recommended process of saving the SketchUp model first and then updating LayOut. Here are the steps I have taken so far:

  • I tried moving and renaming both the SketchUp and LayOut files.
  • I attempted to unlink, relink, and resave the files.
  • I reset both SketchUp and LayOut preferences and plist in the OSX library.
  • I reset and repaired the permissions of my hard drive.
  • Finally, I restarted my computer.

Despite these attempts, I am still experiencing issues with the modified Camera properties and the resetting of the scale, as mentioned earlier. I appreciate any further assistance you can provide.

There have been other problem reports mostly from from Mac users (but a few on Windows) with shifting Cameras when “Preserve Scale on Resize” is checked.

Thank you Dan.

1 Like

This topic was automatically closed after 186 days. New replies are no longer allowed.