If your LayOut Viewports aren't updating, here are some tips!

This comes up a lot, so here’s some tips:
If your viewports aren’t updating in Layout, it’s likely from one of these reasons:

  1. If you change the SketchUp Model panel settings in Layout, they will override the Scene settings, and those properties will persist to any copied viewports in Layout, even if you change the scene. To regain the SketchUp Scene properties for a selected viewport, open the SketchUp Model panel in Layout (use the Window menu if you don’t see it) and click the “Reset” buttons next to the relevant property categories, such as Camera, especially. If you don’t see “Reset” buttons, then that’s not the issue.

  2. Try right-clicking on a viewport and hit “Render Model.” If the Viewport isn’t set to Auto-Render in the SketchUp Model panel in Layout (it just says “Auto” with a checkbox next ot it), then changes won’t show until you re-render the viewport.

  3. Make sure you’re “updating” Scenes in SketchUp after making changes (right-click on the scene tab and hit Update), and then saving the SketchUp model file, and then updating the model reference in Layout.

  4. Your model may have become unlinked. This article and the following section will help: Managing Changes and Updates to SketchUp Files within LayOut | SketchUp Help
    If Relinking the file still results in a “Missing” file reference, then try the following tip:

  5. If there are special characters in your folder or file names along the filepath of the reference, then the model link will break and LayOut will only reference the internal clone model. Once you remove those special characters, then you should be able to go to File > Document Setup > References and Relink the model to your model’s file location.

2 Likes